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CHAPTER 1  SYSTEM SETUP 

Software 

If a complete system was purchased from Med Associates, Inc. the Threshold software has been 
installed and is ready for use. If Threshold is being installed on a new PC or is being reinstalled, 
place the CD in the computer’s CD drive and click Install Threshold at the welcome splash 
screen. If the CD does not auto-start, navigate to the CD drive in Windows Explorer and double 
click the “autorun.exe” file to begin the installation. 

DIG-744 Configuration 

Once the software and driver installation is complete shut down the PC and install the DIG-744 
card according to the directions for installing PCI cards included with the computer. Turn the 
computer back on and run the Measurement & Automation program found on the desktop.  
Under Devices and Interfaces the PCI-6023E (DIG-744) card will be listed.  Click on the PCI-6023E 
card and click the Properties button.  Click on the AI tab and set the mode to Referenced Single 
Ended, as shown in Figure 1-1. Click OK or Apply and OK to save the configuration changes. 

Figure 1-1 - Configuring the PCI-6023E (DIG-744) Card 

 
 

System Preferences  

From the menu bar select File > Preferences to open the Preferences screen (Figure 1-2). Table 
1-1 explains the available options. Click OK when all preferences are set. 
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Figure 1-2 - Preferences 

 
 

Table 1-1 - Preference Options 

Item Description 

Number of Chambers Sets number of chambers being used 

Resolution Sets data acquisition in milliseconds 

Graph History Sets number of seconds of data to display on the graph 

Voltage Readings Absolute – Voltage recorded as 0 – 10V 

Relative – Voltage recorded as -10 – 10V. See Threshold Data 

Synchronize Recording With Event Only record data when selected event is activated 

Save Text Summary Files Saves a text summary file of the experiment 

Save CSV Summary Files Saves a comma separated value (csv) version of the text summary. 
May be imported to a spreadsheet 

Save CSV Batch Summary Files Saves a single csv data file that contains the results of multiple 
experiments 

Save CSV Raw Data Files Converts the raw data file to a spreadsheet file. These files may be 
very large so use caution when using this option 
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Automatic File Naming Automatically names data files based on experiment, group and 
subject 

Consolidate files to a single 
spreadsheet file 

Creates a Threshold v1 .out spreadsheet file. Only used for 
backwards compatibility with v1 analysis software 

Data Directory (Browse) Selects location to store data files 

Data Subdirectory Options Creates a sub-directory in the data directory for each experiment 
based on selected item 

NI-DAQ Device Number Sets the number of the DIG-744 card to use. The device number is 
listed in the Measurement and Automation program 

Number of Chambers per NI-DAQ 
Device 

Sets number of chambers connected to each DIG-744 card 

Chamber Cal ibration 

Click File > Calibrate to open the calibration screen. Each chamber has a graph showing the 
upper threshold (blue), lower threshold (green), and current input value (red). Line colors are 
adjustable through the Colors menu. The upper and lower thresholds are adjustable so optimal 
upper and lower thresholds can be derived before experiments are run. 

Figure 1-3 - Calibration Screens 
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Use the up and down arrows on the upper & lower threshold boxes to set the respective 
threshold values. Click File > Stop Calibration when all settings are complete. 

Menu Options  

File Menu 

Item Description 

Preferences See System Preferences. 

Calibrate Calibrate the inputs for each chamber 

Exit Exit Threshold 

 

Experiment Menu 

Item Description 

Start Experiment Displays the experiment form and allows the experiment to be started 

Start Chambers Start the currently configured chambers 

Stop Chambers Stop currently running chambers and saves the data 

Abort Chambers Abort currently running chambers without saving data 

Pause Chambers Pause currently running chambers 

Resume Chambers Resume paused chambers 

 

View Menu 

Item Description 

View Text Summary File Display summary text data files 

View CSV Summary File Display CSV summary data files 

View CSV Batch Summary File Display CSV batch summary files 

View Raw Data File Display raw data files 

View CSV Raw Data File Display CSV raw data files 

 

Create Menu 

Item Description 

Create Text Summary File Creates a text summary file from a raw data file 
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Create CSV Summary File Creates a CSV summary file from a raw data file 

Create CSV Batch Summary 
File 

Creates a CSV batch summary file from a set of raw data files 

Create CSV Raw Data File Creates a CSV raw data file from a raw data file 

Create Threshold Version 2 
Export File 

Converts raw data files to the old Threshold Version 2 exported data files 
format 

 

NOTE:  CSV (Comma-Separated Value) file format is a common spreadsheet format that can be 
viewed using any spreadsheet application. 

Color Menu 

Allows user to adjust colors of data and event lines. 

Window Menu 

Options for arranging experiment windows 

About Menu 

Displays copyright and version information about the Threshold software. 
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CHAPTER 2  COLLECTING DATA 

Experiment Setup 

To begin collecting Threshold data select Experiment > Start Experiment to open the 
Experiment Settings screen.  

Figure 2-1 - Experiment Settings 

 
 

If a new experiment is to be created, or an existing one is to be modified, click Add Experiment 
or Modify Experiment, set the experiment parameters in the Modify Experiment screen (Figure 
2-2 & Table 2-1), and click OK to be returned to the Experiment Settings screen.  

Highlight chamber 1 and select the experiment from the Experiment ID drop down box, the 
experiment settings will load into the right hand portion of the screen. The experiment ID and 
Group ID can be copied to all chambers being run by clicking Copy data to all chambers. Click 
each chamber number being used and enter the Subject ID, Subject Info and Comment (if 
desired). Click Start Experiment, select the chambers to start in the next screen and click Start 
to begin data collection. 

While collecting data the Experiment menu allows the user to start, stop, pause, resume and 
abort chambers as needed. See Experiment Menu. 
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Figure 2-2 - Modify Experiment 

 
 

Table 2-1 - Experiment Settings 

Item Description 

Experiment Time Length of trial in minutes 

Number of Blocks Number of blocks the trial is broken into 

Block Time Block duration in seconds 

Upper Threshold Value of upper threshold from 0 – 100 

Lower Threshold Value of lower threshold from 0 – 100 

Start Trigger Value from 0 – 100 that must be exceeded before Threshold will start recording 
data. Set to 0 to disable this feature 

Pre & Post Ignore 1 & 2  The event number that is used for Pre Ignore 1 and Post Ignore 1. 

Pre Ignore 1 & 2 Time Number of milliseconds of data ignored prior to the Pre Ignore 1 & 2 events. 
Only affects the summary data. Must be an even multiple of the resolution. 

Post Ignore 1 & 2 Time Number of milliseconds of data ignored after the Post Ignore 1 & 2 events. Only 
affects the summary data. Must be an even multiple of the resolution. 

Event Labels 1-4 Descriptive labels for events implemented in the experiment 
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Threshold Data  

 
Threshold voltage data (values) are acquired from a DIG-744 card (also known as a NI PCI-
6023E), which is attached to a load-cell placed underneath the animal. The load-cell measures 
pressure, and outputs the pressure value in volts.  
The DIG-744 reads voltage values between –10 volts and 10 volts, with a precision of 4.88 
millivolts. When Threshold is in absolute voltage mode, all negative voltages are converted to 
positive values, therefore –5 volts becomes 5 volts. In relative voltage mode, Threshold keeps 
the voltage values between –10 and 10 volts. After the voltage value has been received, 
Threshold multiplies the value by ten. Therefore in absolute mode Threshold has a value scale 
from 0 to 100, and in relative mode Threshold has a value scale from –100 to 100.  
 
Threshold events are acquired via software calls, either through MED-PC or third party software. 
The functions that are used to turn Threshold events on or off look like the following:  
 
void EventOn(int box, int event);  
void EventOff(int box, int event);  
 

The box is a number between one and thirty-two, and the event is a number between one and 
four. On the Threshold CD there is a directory called “MED-PC Files”, and in that directory are 
two files, thresh.hed and thresh.mpc. To turn Threshold events on and off from MED-PC, include 
the file thresh.hed in the MED-PC user.pas file.  
 
{Place $I Filename.HED files here.}  
{$I THRESH.HED} 
  

Then from inside the MED-PC program issue the EventOn command as follows:  
 
S.S.1,  
S1, \ Wait for Start command and then tell  
    \ Threshold to start recording data  
#START: ~EventOn(Box, 1);~ ---> S2 
  

and the same syntax applies to the EventOff command.  
 
S2, \ Run for 5 minutes and then tell  
    \ Threshold to stop recording data  
5': ~EventOff(Box, 1);~ ---> STOPKILL 
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CHAPTER 3  USING THRESHOLD VIEWER 
When the Threshold Viewer software is opened, the screen depicted in Figure 3-1 will appear. 

Figure 3-1– Threshold Viewer main screen 

 

Menu Options  

File Menu: 

• Open Data File – Opens a Threshold raw data file. 

• Close Data File – Closes a data file. 

• Print – Prints the current screen. 

• Import | Tail Suspension data files – Imports Tail Suspension data files to Threshold 
format raw data files. 

• Exit – Exits the program. 

Controls Menu: 

• Play – Scrolls forward through the data file. 

• Pause – Stops scrolling the data file. 

• Rewind – Scrolls backwards through the data file. 
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• Fast Forward – Scrolls forward through the data file ten times faster than play. 

• Fast Reverse – Scrolls backwards through the data file ten times faster than rewind. 

• Beginning – Goes to the beginning of the data file. 

• End – Goes to the end of the data file. 

• Refresh – Refreshes the screen. 

Options Menu: 

• Colors – Modifies the color of the thresholds, events, tracking and data lines. 

• Current File – Selects the current file.  Only the current files events are displayed, 
and the program cannot scroll past the end of the current file. 

View Menu: 

• File Information – Displays information about the open files and allows 
recalculation of threshold parameters. 

• Zoom – Changes the scale of the data graph.  If the tracking bars would be moved 
off the screen due to modifying the scale, the tracking bars are moved to a location 
that is visible on the screen. 

• Tracking – Turns the tracking line (Trace 2) on and off. 

• Lock Trace 1 – Locks the Trace 1 line to the current position. 

• Lock Trace 2 – Locks the Trace 2 line to the current position. 

• View Text Summary File – Displays summary files. 

• View CSV Summary File – Displays CSV summary files. 

• View CSV Batch Summary File – Displays CSV batch summary files. 

• View CSV Raw Data File – Displays CSV raw data files. 

Create Menu. 

• Create Text Summary File – Creates a text summary file from a raw data file. 

• Create CSV Summary File – Creates a CSV summary file from a raw data file. 

• Create CSV Batch Summary File – Creates a CSV batch summary file from a set of 
raw data files. 

• Create CSV Raw Data File – Creates a CSV raw data file from a raw data file. 

• Create Threshold Version 2 Export File – Creates an export file in the .out file 
format compatible with Threshold Version 2. 

The Help menu displays version number and copyright information. 
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Fi le Information 

The file information screen displays pertinent information about the experiment, and allows 
several experiment parameters to be modified and recalculated.  When the Recalculate button 
is clicked a Threshold summary file will be appended to with the recalculated data.  For 
example, if the original experiment was run with an upper threshold of 40, the upper threshold 
can be changed to 30 and the experiment will be reanalyzed with the new analysis data saved in 
the summary file. 

 

Figure 3-2– File Information screen 
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APPENDIX A  DATA FILE FORMATS 

Summary Fi les  

Summary data files contain the following information: 

• Printed on – The date and time the summary file was printed. 

• Threshold Summary, Version – Displays which version of Threshold created the 
summary file. 

• Experiment ID – The experiment ID. 

• Group ID – The group ID. 

• Subject ID – The subject ID. 

• Subject Info – The subject info. 

• Comment – The comment. 

• Session # - The session number. 

• Experiment Length – The length of the experiment in minutes. 

• Block Time – The length of each block in seconds. 

• Number of Blocks – The number of blocks in the experiment. 

• Experiment Date and Time – The date and time the experiment was started. 

• Actual Run Time – The actual amount of time the experiment ran for, in 
hour:minute:second:millisecond format. 

• Resolution – The rate at which data was collected, in milliseconds. 

• Voltage Readings – Whether the voltage was recorded in absolute mode (took the 
absolute value of the incoming voltage, from zero to ten volts), or relative mode (did not 
modify the voltage value, from negative ten to ten volts). 

• Upper Threshold – The upper threshold value. 

• Lower Threshold – The lower threshold value. 

• Ignore Event 1 – The event number that is used for Pre Ignore 1 and Post Ignore 1. 

• Pre Ignore 1 - Contains the number of milliseconds to ignore data that occurred prior to 
Ignore Event 1.  This setting only affects the following summary fields, it does not affect 
the raw data – Time Below Lower Threshold, Time Above Lower Threshold, Time Above 
Upper Threshold, Lower Threshold Crossings, Upper Threshold Crossings, Sum Above 
Lower Threshold, Sum Above Upper Threshold. 

• Post Ignore 1 – Contains the number of milliseconds to ignore data that occurred after 
Ignore Event 1. 
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• Ignore Event 2 – The event number that is used for Pre Ignore 2 and Post Ignore 2. 

• Pre Ignore 2 – Contains the number of milliseconds to ignore data that occurred prior to 
Ignore Event 2. 

• Post Ignore 2 – Contains the number of milliseconds to ignore data that occurred after 
Ignore Event 2. 

• Event 1-4 Labels – The name of the respective event. 

• Summary Blocks – The analysis of the raw data broken into blocks. 

• Time Below Lower Threshold - The amount of time that the data was below the lower 
threshold. 

• Time Above Lower Threshold - The amount of time that the data was less than the 
upper threshold and greater than or equal to the lower threshold. 

• Time Above Upper Threshold - The amount of time that the data was greater than or 
equal to the upper threshold. 

• Lower Threshold Crossings - The number of times where the data was below the lower 
threshold, than became greater than or equal to the lower threshold. 

• Upper Threshold Crossings - The number of times where the data was below the upper 
threshold, than became greater than or equal to the upper threshold. 

• Sum Above Lower Threshold - The sum of the data when the data was less than the 
upper threshold and greater than or equal to the lower threshold. 

• Sum Above Upper Threshold - The sum of the data when the data was greater than or 
equal to the upper threshold. 
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Following is an example of a typical summary file. 

 

Printed on : 05/20/2010 11:28:05 
 
                        Threshold Summary, Version 3.0 
 
Experiment ID: First Test 
Group ID     : 10ml of saline used 
Subject ID   : andy (mouse #1) 
Subject Info : Weight - 25 grams 
Comment      : andy - first test 
Session #    : 1 
 
Experiment Length        : 5 minutes 
Block Time               : 60 seconds 
Number of Blocks         : 5 
Experiment Date and Time : 05/20/2010 11:23:04 
 
Actual Run Time          : 0:05:00.000 
Resolution               : 10 milliseconds 
Relative Voltage Readings 
Upper Threshold          : 50.0 
Lower Threshold          : 20.0 
Ignore Event 1           : 1 
Pre Ignore 1             : 50 milliseconds 
Post Ignore 1            : 0 milliseconds 
Ignore Event 2           : 4 
Pre Ignore 2             : 0 milliseconds 
Post Ignore 2            : 20 milliseconds 
Event 1 Label            : Light 
Event 2 Label            : Shock 
Event 3 Label            : Lever 1 
Event 4 Label            : Lever 2 
 
------------------Summary Blocks------------------ 
 
Block Number 1 
Time Below Lower Threshold : 0:00:34.260 
Time Above Lower Threshold : 0:00:07.020 
Time Above Upper Threshold : 0:00:18.720 
Lower Threshold Crossings  : 18 
Upper Threshold Crossings  : 12 
Sum Above Lower Threshold  : 24351.5 
Sum Above Upper Threshold  : 157338.9 
 
Block Number 2 
Time Below Lower Threshold : 0:00:34.280 
Time Above Lower Threshold : 0:00:07.000 
Time Above Upper Threshold : 0:00:18.720 
Lower Threshold Crossings  : 14 
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Upper Threshold Crossings  : 12 
Sum Above Lower Threshold  : 24306.4 
Sum Above Upper Threshold  : 157311.7 
 
Block Number 3 
Time Below Lower Threshold : 0:00:34.980 
Time Above Lower Threshold : 0:00:06.640 
Time Above Upper Threshold : 0:00:18.380 
Lower Threshold Crossings  : 16 
Upper Threshold Crossings  : 12 
Sum Above Lower Threshold  : 23137.0 
Sum Above Upper Threshold  : 155006.3 
 
Block Number 4 
Time Below Lower Threshold : 0:00:34.960 
Time Above Lower Threshold : 0:00:06.960 
Time Above Upper Threshold : 0:00:18.080 
Lower Threshold Crossings  : 19 
Upper Threshold Crossings  : 12 
Sum Above Lower Threshold  : 24204.5 
Sum Above Upper Threshold  : 150987.0 
 

Block Number 5 
Time Below Lower Threshold : 0:00:35.240 
Time Above Lower Threshold : 0:00:06.620 
Time Above Upper Threshold : 0:00:18.140 
Lower Threshold Crossings  : 15 
Upper Threshold Crossings  : 11 
Sum Above Lower Threshold  : 23087.2 
Sum Above Upper Threshold  : 152691.7 
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CSV (Comma Separated Value) summary data f i les  

The CSV summary data files created by Threshold contain the summary data in an easy to read 
format that is understood by most spreadsheet programs.  Following is part of a sample CSV file. 

 

Printed on : 10/05/2010 09:56:29     
        
Threshold Summary Recalculated by Threshold Viewer   
        
Experiment ID 5 minute test      
Group ID        
Subject ID       
Subject Info       
Comment        
Experiment Length 300 seconds      
Block Time 60 seconds      
Number of Blocks 5       
Experiment Date and 
Time 9/27/2010 10:15 

 

      
        
Actual Run Time 5:00.0       
Resolution 1 milliseconds      
Absolute Voltage Readings      
Upper Threshold 60       
Lower Threshold 30       
Event 1 Label       
Event 2 Label       
Event 3 Label       
Event 4 Label       
        
------------------Summary Blocks---
--- 

---------
- 

---------
-   

All times are in seconds.      

Block 
Number 

Time 
Below 
Lower 

Threshold 

Time 
Above 
Lower 

Threshold 

Time 
Above 
Upper 

Threshold 

Lower 
Threshold 
Crossings 

Upper 
Threshold 
Crossings 

Sum Above 
Lower 

Threshold 

Sum Above 
Upper 

Threshold 

1 46.323 4.454 9.223 8 7 199698 812765.8 
2 14.040 14.281 31.680 24 24 639280.2 2793319 
3 13.924 14.395 31.681 24 24 645375.8 2793047 
4 13.923 14.390 31.687 27 24 645022.4 2793226 
5 13.920 14.400 31.680 24 24 645472.7 2792550 
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CSV (Comma Separated Value) batch summary fi les 

The CSV batch summary files created by Threshold contain the summary data from multiple 
experiments in an easy to read format that is understood by most spreadsheet programs.  
Following is part of a sample CSV file. 

Figure A1.1 – Sample CSV File 

 

CSV (Comma Separated Value) raw data fi les 

The CSV raw data files created by Threshold contain the raw data in an easy to read format that 
is understood by most spreadsheet programs.  Following is part of a sample CSV file. 

The first value is the raw value.  The raw value is between –100.000 and 100.000.  The raw value 
is the voltage read from the DIG-744 (NI-DAQ card) multiplied by 10. 

The second, third, fourth, and fifth values are events one through four, respectively. 

So the following line would be interpreted as value: 2.344, event 1: off, event 2: off, event 3: off, 
event 4: off. 

2.344, 0, 0, 0, 0 
2.344, 0, 0, 0, 0 
2.344, 0, 0, 0, 0 
2.344, 0, 0, 0, 0 
2.344, 0, 0, 0, 0 
2.393, 0, 0, 0, 0 
2.344, 1, 1, 1, 1 
37.988, 1, 1, 1, 1 
38.574, 1, 1, 1, 1 
38.916, 1, 1, 1, 1 
39.063, 1, 1, 1, 1 
39.111, 1, 1, 1, 1 
39.160, 1, 1, 1, 1 
39.258, 1, 1, 1, 1 
The above line would be interpreted as value: 39.258, event 1: on, event 2: on, event 3: on, 
event 4: on. 
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APPENDIX B CONTACT INFORMATION 
Please contact MED Associates, Inc. for information regarding any of our products.   

Visit our website at www.med-associates.com for contact information. 

For technical questions, email support@med-associates.com. 
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