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CHAPTER 1  | INTRODUCTION 
Empirical evidence suggests that ultrasonic vocalization (USV) can be used as a measure of motivational 
and emotional state (Knutson et al. 2002). For instance, rodent pups emit distress USVs as a 
consequence of maternal severance or hypothermia (Blumberg & Alberts, 1990; Hofer & Shair, 1993; 
Sokoloff & Blumberg, 2005) and maternal responsiveness is proportional to the number of calls mouse 
pups emit (D’Amato et al. 2005). Brudzynski & Pniak (2002) observed that mature laboratory rats emit 
USVs in anticipation of social contact. Furthermore, USVs are produced as a result of painful stimulation 
during fear conditioning (Antoniadis & McDonald, 1999; Lee et al, 2001) and as a result of morphine or 
ethanol withdrawal (Vivian & Miczek, 1991; Moy et al. 2000, respectively). Although the empirical 
evidence is somewhat inconclusive, one theory of motivation states that rat USVs can be divided 
between 2 different kilohertz bandwidths. Vocalizations ranging between 50-70 kHz represent positive 
affective states, but those in the 22 kHz range are characteristic of negative affective states (Knutson et 
al. 2002). Whether or not this theory continues to garner empirical support, the evidence is clear that 
USVs are good indicators of underlying motivational state.   

USVs can be divided into four general classes: (1) distress calls, (2) long calls, (3) short calls, and (4) alarm 
calls. Neonatal rat pups emit distress USVs at the average frequency of 40 kHz (Sokoloff & Blumberg, 
2005) and this frequency decreases with age. Mature rats produce long calls that are just above the 
audible range at 22 kHz (65-85 db), and these calls last for 300-4000 ms and have a narrow bandwidth of 
1-6 kHz (Sales 1972). Long calls are associated with sexual behavior and aggression (Barfield et al 1979). 
Short calls (32-96 kHz, 30-65 ms) occur during high levels of physical activity, arousal, and social contact 
(Knutson et al. 1998). Finally, alarm calls (22 kHz) communicate the presence of a predator or are 
produced as the result of experiencing a painful event (Blanchard et al. 1991; Antoniadis & McDonald, 
1999; respectively). 
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Dependent Variables  

The Med Associates, Inc. ANL-937-1 Ultrasonic Vocalization (USV) Detector is designed to capture the 
occurrence of ultrasonic vocalizations to provide quantitative data on a subject’s motivational, 
emotional, or communicative state. The USV detector samples ultrasonic frequencies every 30 
milliseconds and differentiates between two user-defined bandwidths.  

MED-PC® can be used in conjunction with the USV detector to turn on the detector, and correlate 
events such as food or shock delivery with the USV data acquisition. See Chapter 8, Using MED-PC® 
Inputs/Outputs for details. 

USV Occurrences 

The USV data illustrate the onset and duration of vocalizations occurring within two user-defined 
frequency bands above an amplitude threshold. Refer to  Chapter 5, Capturing Ultrasonic Data, for 
more information. 

Sonogram 

The Med USV Viewer data analysis utility included with the Med USV Detector produces a sonogram 
that graphs USV occurrences in kilohertz over time.  Thus, the sonogram provides information on the 
duration and frequency of a USV, as well as relative changes in pitch.  See Chapter 7, The MED USV 
Viewer, for more information on the sonogram analysis. 

Spectrogram 

The Med USV Viewer can also produce a spectrogram which is a three-dimensional surface plot that 
illustrates frequency, in kilohertz, by time and by amplitude in decibels. The spectrogram is particularly 
well suited to revealing ultrasonic artifacts in the testing environment, such as ultrasonic vibrations 
created by some fluorescent lamps or computer monitors.  Once artifacts are recognized, the bandwidth 
can be adjusted to isolate USVs from other ultrasonic events. See Chapter 6, Viewing The Spectrogram 
and Chapter 7, The MED USV Viewer for details.  

Cumulative Record 

Data can be viewed as an event plot or in a cumulative fashion to represent the rate of USV occurrences. 
Each occurrence of an ultrasonic vocalization causes an increase on MED-PC®’s SoftCR Pro® cumulative 
plot. Med Associates provides the cumulative record as a method of estimating the rate of USV 
occurrences. Refer to Chapter 8, Using MED-PC® Inputs/Outputs, for further information on how to 
integrate MED-PC® with the USV Detector. 
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CHAPTER 2  | SOFTWARE INSTALLATION 

Software Instal lation  

If the computer was purchased as part of USV Detector system from Med Associates, Inc., the SOF-937-1 
USV Detector software and driver installation was completed at the factory. If the computer was not 
purchased from Med Associates or was not a part of the system, follow the instructions below to install 
the drivers and software.  
 
Before beginning the software installation, phone, fax or e-mail Med Associates with the registration 
information in order to receive the software installation password. This password will be necessary 
during the software installation process.  
 
Insert the SOF-937-1 Ultrasonic Vocalization Detector software CD into the CD drive and at the 
welcome screen click Install. If the CD does not auto-start, navigate to the CD drive in Windows Explorer 
and double click the “autorun.exe” file and click Install at the welcome screen. Successful installation of 
each component will be indicated by a green check mark, a red X will indicate an unsuccessful 
installation. When prompted enter the user name, company name and software installation password. 
When the installation completes, click Finish. 
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CHAPTER 3  | WIRING GUIDE 

Stand-Alone Operation 

NOTE:   Do not connect or disconnect the unidirectional microphone when the ANL-937-1 is 
connected to 28-volt power.  Doing so may cause damage to the detector. 

Refer to Figure 3-1 when completing the following steps. 

 

Figure 3-1 - Stand Alone Operation Connections 

 

  

1. Connect the USB port on the ANL-937-1 USV Detector to any available USB port on the computer 
using the USB cable provided. 

2. Connect the unidirectional microphone to the Transducer Input connector on the ANL-937-1 USV 
Detector.   

3. Connect the +28 VDC connector on the ANL-937-1 USV Detector to the SG-501 power supply using 
the SG-937P-10 power cable. 
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MED-PC® Control led Operation 

NOTE:   Do not connect or disconnect the unidirectional microphone when the ANL-937-1 is 
connected to the MED Inputs on the connection panel. The ANL-937-1 receives +28 VDC 
power from these connections. Doing so may cause damage to the microphone. 

Follow the instructions in the MED-PC® User’s Guide, DOC-010, for information on hardware and 
software installation and hardware configuration. All general information pertaining to translating and 
compiling the ANL_937.mpc program, and modifying the MSN code, can be found in the MED-PC® 
Programmer’s Manual, DOC-003. Refer to Figure 3-2 when following the steps below. 

 

Figure 3-2 – MED-PC® Connection Panel Connections 

 
 

1. Connect the unidirectional microphone to the Transducer Input connector on the ANL-937-1 USV 
Detector, as shown in Figure 3-1. 

2. Connect the To MED Input 1 connector (Band 1) on the ANL-937-1 to Input 1 on the SG-716B 
Connection Panel using a 3-pin Molex cable. 

3. Connect the To MED Input 2 connector (Band 2) on the ANL-937-1 to Input 2 on the SG-716B 
Connection Panel using a 3-pin Molex cable. 

4. Connect the From MED Output connector on the ANL-937-1 to Output 1 on the SG-716B Connection 
Panel using a 3-pin Molex cable.   

5. For FFT Data collection, connect the USB port on the ANL-937-1 USV Detector to any available USB 
port on the PC using the USB cable provided. 
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CHAPTER 4  | DEVICE IDS AND OFFSETS 
Both the Device IDs and offsets are factory preset, but if for any reason these values need to be changed 
or if a new ANL-937-1 is being added to the system, the following steps explain the procedure.    

1. Ensure that none of the ANL-937-1 devices are connected to the USB port on the computer and 
open the USV Application software.  The prompt shown in Figure 4-1 will appear.  Connect the first 
device to the USB port.  This device will automatically be assigned Device ID 1.   

 

Figure 4-1 - Setup of the ANl-937-1 

 
 

2. Once the device is connected and has been recognized by the software, the screen shown in Figure 
4-2 will appear.  Select the Microphone Offset from the pull down menu (This number is marked on 
each microphone).  If there are additional devices to setup, select OK.  If this is the only box to 
setup, select Last Box. 

 

Figure 4-2 - Selecting the Device Offset 
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3. If OK was selected from the step above, the screen shown in Figure 4-3 will appear.  Follow the 
prompt by disconnecting Device ID 1 from the USB port and plug in the next ANL-937-1.  This device 
will automatically be assigned Device ID 2.   

 

Figure 4-3 - Setup for Second ANL-937-1 

 
 

4. Follow steps 1-3 for each additional ANL-937-1 and select Last Box when the offset has been 
selected for the final device.  The screen shown in Figure 4-4 will appear.  Select OK and connect all 
of the ANL-937-1 devices that have been setup.  When the application is restarted, the Device ID 
tabs will be displayed, as shown in Figure 5-1. 

 

Figure 4-4 - ANL-937-1 Setup Complete 
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CHAPTER 5  | CAPTURING ULTRASONIC DATA 
Upon launching the MED USV application the screen in Figure 5-1 will appear if the ANL-937-1 is running 
current firmware. ANL-937-1s running older firmware will have a display as presented in Figure 5-2 
where the All FFT Data and Maximum Band Amplitude options are grayed out.  

Enter the desired values in the Low (kHz), High (kHz) and Threshold (dB) fields. In Figure 5-1, “Band 1” 
will capture ultrasonic vocalizations occurring between 20 and 50 kHz, if they occur at 40 dB or higher. 
“Band 2” will capture vocalizations occurring between 50 and 70 kHz at 40 dB or higher. In this example 
a vocalization of 50 dB at 50 kHz will fall within the parameters set for both bands.  

Once the values for bands 1 and 2 and the threshold are set, set the Save FFT Data option, the 
Threshold Criteria option, and the Enable MED Input option. Then click the Update button to apply the 
settings.   

The MED USV software can be used with up to 16 devices.  To configure each device independently, 
select the device to configure by clicking on the Device ID tab.  To configure all devices with the same 
settings, select Configure Parameters > Set All, make a selection and then click the Update button.   

 

NOTE:  Acceptable band frequencies range from 20–100 kHz. The amplitude threshold limits are 
between 10-150 dB. Bands 1 and 2 may overlap.  

 

After clicking Update, click the Browse button to supply a data file name and save to location. Then click 
Start to begin data acquisition. 

 

Figure 5-1 - USV Application Display 
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Figure 5-2 - USV Application Display With Disabled Items 

 
 

Menu Options 

• File Menu 
o Exit: Exits the MED USV application. 

• Configure Parameters Menu 
o Set All: 
 Med Input: 
• Disable: The MED Input will be disabled for all devices. 
• Enable: The MED Input will be enabled for all devices. 

NOTE:  Enable MED Input should only be selected if the ANL-937-1 is being used in conjunction with 
the optional MED-PC® software.  Refer to Chapter 8, Using MED-PC® Inputs/Outputs, for more 
information. 

 FFT Data: 
• All FFT Data: All FFT Data will be saved. 
• Only When Threshold Exceeded: FFT data will only be saved when the threshold is 

exceeded. 
 Threshold Criteria: 
• Maximum Band Amplitude: The dB threshold is calculated using the maximum band 

amplitude. 
• Total Band Power: The dB threshold is calculated using the total band power. 
 Same As: Sets the same parameters for all connected devices based on the currently selected 

device. The Update button must be clicked on each device, or the Configure Parameters > 
Update All menu option must be selected to apply the settings to the hardware. 

o Update All: Parameter settings will be sent to all devices with an enabled Update button and valid 
band settings. Any invalid settings will cause a warning message to appear, and the Update All 
command will not be completed. Correct any invalid settings and select Update All again. 
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o Reset All: The software will reset the settings on all connected ANL-937-1s to the default values 
and update the Device ID tabs. This selection should be made whenever a new ANL-937-1 is 
connected to the computer, or if a Device ID tab is not appearing. 

• Help Menu 
o ANL-937-1 Manual: Opens the .pdf version of this manual. 
o About…: Provides the Ultrasonic Vocalization Detector software version information. 

 
Data Collection Options 

• Low (kHz): Vocalizations at frequencies below this cut-off value will be disregarded by the 
software. The valid frequency range is between 20 kHz and 100 kHz. 

• High (kHz): Vocalizations at frequencies above this cut-off value will be disregarded by the 
software. The valid frequency range is between 20 kHz and 100 kHz. 

• Threshold: Vocalizations must occur at an amplitude greater than this value in ordered to be 
recorded by the software. The valid range is between 10 dB and 150 dB. 

• Band 1: The first frequency range of interest. 
• Band 2: The second frequency range of interest. 
• Update: After making changes to the options click the Update button to apply the changes to the 

hardware. If any settings are invalid, an error message indicating which setting is incorrect will 
appear. 

• Save FFT Data: 
o All FFT Data: Records all FFT data for the experiment duration. 
o Only When Threshold Exceeded: Only records FFT data when the amplitude threshold has been 

exceeded. 
• Threshold Criteria: 
o Maximum Band Amplitude: The dB threshold is calculated using the maximum band amplitude. 
o Total Band Power: The dB threshold is calculated using the total band power. 

• Enable MED Input: Check the Enable MED Input box to facilitate the starting and stopping of the 
ANL-937-1 from within a MED-PC® protocol. 

NOTE:  Select Enable MED Input only if the ANL-937-1 is being used in conjunction with the optional 
MED-PC® software.  Refer to Chapter 8, Using MED-PC® Inputs/Outputs, for more information. 

• Browse: Click the Browse button to set the data file name and save to location. The data file 
information must be set to enable the Start button. 

• Start: Click Start to begin data collection. 
• Stop: Click Stop at any point after clicking Start to discontinue data collection. 

NOTE: Data will be automatically saved as a “*.bin” file.  For instructions on how to access the *.bin file, 
refer to Chapter 6, Viewing the Spectrogram and Chapter 7, The MED USV Viewer.  
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CHAPTER 6  | VIEWING THE SPECTROGRAM 
The *.bin files created during USV data acquisition can be accessed using the provided macros for 
Microsoft Excel® or with the Med USV Viewer (see Chapter 7, The MED USV Viewer). The macros 
include a graphing utility that creates the spectrogram.  

Open Microsoft Excel® and select File > Open, and browse to C:\Program Files\Med 
Associates\Ultrasonic Vocalization or C:\Program Files(x86)\Med Associates\Ultrasonic Vocalization 
depending on your operating system. If using Microsoft Excel® 2000 or 2003, select MED-
USV_2000_v2.xls and click Open.  If using Microsoft Excel® 2007 or higher, select MED-
USV_2007_v2.xls and click Open.   

Opening a Macro 

Microsoft Excel® 2000 or 2003 

After opening MED-USV_2000_v2.xls, the screen shown below should appear.  Click Enable Macros.  If 
this screen does not appear, select Tools > Macro > Security, and set the security level to “medium.” 

 

Figure 6-1 - Enable the Excel® Macro 

 
 

Once the Excel® workbook is open, select Tools > Macro > Macros….  

Figure 6-2 - Select the Macro Function 
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Select the macro named GetUSV, and click Run. Then select the *.bin data file of interest. 

 

Figure 6-3 - Using the "GetUSV" Macro 

       

Microsoft Excel® 2007 or higher 

Open MED-USV_2007_v2.xls in Excel® the screen Figure 6-4 will appear.  Depending on the security 
settings, a security warning may appear, as shown below.  If it does, click Options… and the screen 
shown in Figure 6-5 will appear. Click Enable this content, then click OK. 

 

Figure 6-4 – Excel Security Warning 
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Figure 6-5 – Excel 2007 Security Alert 
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The menu options that allow the user to run and record macros appear on the Developer tab, which is 
not visible by default.  In order to view the Developer tab, click on the Office Button, and then click on 
the Excel Options button.  The screen shown in Figure 6-6 will appear. 

Enable Show Developer tab in the Ribbon and click OK.  The Developer tab should now appear on the 
ribbon. 

 

Figure 6-6 – Excel 2007 Options Screen 
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Click the Macros button on the Developer tab and the screen in Figure 6-7 will appear.  Highlight the 
macro named GetUSV and click Run. Select the *.bin data file of interest and click Open. 

Figure 6-7 – Excel 2007 Macro Menu 

 
  

If the screen in Figure 6-7 does not appear, click on the Macro Security button in the Code group (Figure 
6-8) and select Disable all macros with notification (Figure 6-9) and click OK. 

Figure 6-8 - Macro Security Button 
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Figure 6-9 - Macro Settings Screen 
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The Spectrogram Macro “GetUSV” 

Upon opening a *.bin data file, the spectrogram will automatically appear as an Excel® Workbook. Each 
spectrogram is viewed as a “chart” worksheet, and the corresponding raw data are listed on the 
subsequent spreadsheet. 

 

Figure 6-10 – Sample Spectrogram Analysis Using GetUSV Macro 

 
 

 

     

 

USV 

Environmental 
artifacts 

http://www.razelscientific.com/


MED A S SOCI ATES,  I NC.  ANL -93 7-1  ULTR ASO NI C  V OCAL I ZAT IO N  DETECTOR  
 

 - 19 - DOC-043 Rev 1.6   Copyright © 2016 
Med Associates, Inc. 

NOTE: The spectrogram macro utilizes the “surface plot” from Microsoft Excel® that is limited to 255 
continuous cells; therefore, the spectrogram macro is limited to the first 7.5 continuous seconds of an 
experimental session. To view ultrasonic vocalizations that may occur after 7.5 seconds, use the 
“GraphUSV” macro described below.  

Using the “GraphUSV” Macro  

The *.xls worksheet contains the data from which the spectrogram was created. To view a specific 
portion of the data as a spectrogram, select the portion of cells in column D (Figure 6-11) that 
correspond to the interval that is of interest.  

The “GraphUSV” macro can also be used to view ultrasonic events that occur after the first 7.5 
continuous seconds of data acquisition (see the NOTE above). Because of the limitations imposed by 
Microsoft Excel®, only 255 total Excel® cells can be plotted in any single spectrogram. Open “GraphUSV” 
in the same manner as described in the Opening a Macro section of this manual.   

 

Figure 6-11 - Use "GraphUSV" to View a Portion of the *.xls Data 
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Figure 6-12 - The Spectrogram Resulting From the "GraphUSV" Macro 

 

Comparison of Data Options  

The Ultrasonic Vocalization Detector software allows the user to set the threshold value based on the 
Maximum Band Amplitude (MBA) or the Total Band Power (TBP) as well as selecting whether to record 
all FFT data or to only record FFT data while the threshold is met or exceeded. The following figures 
were generated with sample data files that were not produced with live subjects, but were produced in 
an attempt to illustrate the differences between the data options. 

Figure 6-13 provides an example of sample data collected using a 40dB threshold based on the MBA,  
and all FFT data was collected. In Figure 6-14 the FFT data is recorded only when the 40 dB threshold is 
met or exceeded. One can view the “noise” before and between the ultrasonic vocalizations in Figure 
6-13 and not in Figure 6-14. 

Selecting to record all FFT data or only recording FFT data at or above the threshold using the TBP value 
produces similar results. 

dB 
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Figure 6-13 – MBA, 40 dB Threshold, All FFT Data Recorded 

 

 

Figure 6-14 - MBA, 40 dB Threshold, FFT Data Only Recorded At Or Above Threshold 
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The *.xls  Data Fi le  

View the Excel® raw data created from the *.bin file by selecting the spreadsheet corresponding to a 
specific spectrogram chart. Figure 6-15 illustrates a portion of a sample data file that is created when a 
spectrogram is created. Refer to the explanation following Figure 6-15. 

Figure 6-15 - Sample .xlsx Data File 

  

1.) Data file name. 
2.) Date and time data file was recorded. 
3.) Band 1 frequency range and amplitude threshold. 
4.) Band 2 frequency range and amplitude threshold. 
5.) Band 1 power (dB) during the vocalization. This is based on the maximum band amplitude or the 

total band power. 
6.) Band 2 power (dB) during the vocalization. This is based on the maximum band amplitude or the 

total band power. 
7.) Time at which the vocalization occurred in seconds from the start of data acquistion.  
8.) Row 6 is the entire frequency range from 20 kHz to 100 kHz. The values under each frequency 

are the amplitudes at which the frequency occurred during that particular vocalization. 
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CHAPTER 7  | THE MED USV VIEWER 
The MED USV Viewer may be used to produce a spectrogram or a sonogram to view the quantity and 
decibel level of USVs in each user-defined bandwidth. Any *.bin data file created by the ANL-937-1 can 
be examined with the USV Viewer.  

Opening a *.bin f i le with the USV Viewer 

After opening the MED USV Viewer click the View menu and select Sonogram or Spectrogram to view 
either display. Then click File > Open File, navigate to and select the *.bin file to be used and click Open. 
Figure 7-1 is a sample sonogram. Click View and select the other view at any time to switch views. Figure 
7-3 is the spectrogram of the same sample data used in Figure 7-1. 

Figure 7-1 - Sonogram of Sample Data 

 

 

While viewing a sonogram click View > Scroll Forward, or press F8, to scroll forward through the 
timeline. Click View > Scroll Back, or press F7, to scroll backward through the timeline.  

NOTE: The sonogram in the MED USV Viewer plots only the maximum kHz value for each band for any 
given time point; therefore, two data points (band 1 & 2) may exist at any given time.  

The number of USVs for each band, as well as the onset time and length of each USV, appear in the 
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lower right portion of the display, see Figure 7-2 . Clicking on a vocalization start time or length value 
will zoom the sonogram in on that data point. 

 

Figure 7-2 - Onset, Duration and Total Number USVs per Band 

 
 

Figure 7-3 - Spectrogram of Sample Data 

 
 

While viewing a spectrogram the mouse wheel may be used to zoom in or out on the spectrogram. Left 
click and hold the mouse button and move the mouse to rotate the spectrogram around each axis. Click 
View > Restore to Max, or press Ctrl + R, to restore the spectrogram to the default view.  
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Editing Viewer Parameters  

Click File > Edit Parameters to adjust the properties of the USV Viewer sonogram or spectrogram. The 
adjustable parameters depend on whether a sonogram or spectrogram is being viewed, see Figure 7-4 
and Figure 7-5.  

The Y-axis minimum and maximum values are 19 kHz and 101 kHz respectively. To modify the fields, use 
the up/down arrows to the right of each field, or place the cursor in each field and type a numeric value. 
Change the colors corresponding to each decibel range by clicking that decibel range. When all 
modifications have been made, press OK.  

 

Figure 7-4 – Adjustable Sonogram Display Parameters 

 
Figure 7-5 - Adjustable Spectrogram Display Parameters 

 
 

Printing a Sonogram or Spectrogram 

Sonograms and spectrograms may be printed by clicking File > Print, selecting which item is to be 
printed, selecting a printer and clicking Print. Click Cancel to cancel the printing operation. 
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Exporting Data to Microsoft Excel®  

To export data for use in Microsoft Excel®, click File > Export to CSV File and in the “Save USV -> CSV 
File” window supply a file name and save to location.  

To open the .csv data file in Excel® click the open file icon and in the “Open” window set the file type 
drop down to “All Files (*.*)”, select the *.csv file and click Open. See Figure 7-6. 

 

Figure 7-6 - Excel® Spreadsheet From *.csv Data File 

 
 

NOTE: The export function in the USV Viewer creates a data file that does not differ from the file 
created by the GetUSV Macro.  

 

Exporting Data To A Text Fi le  

To create a *.txt data file that may be opened in Notepad, WordPad, or any word processing program 
with the USV Viewer, click File > Save As. In the “Save File As” window supply a file name and save to 
location and click Save. See Figure 7-7. 
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Figure 7-7 - Sample Text Data File in Microsoft Notepad 

 
 

The time of the vocalization onset and the duration of each vocalization are listed underneath each 
“band” heading. The data reflect only those vocalizations that occurred above the user-defined decibel 
threshold and within each band range. 

Help Menu 

The help menu provides access to the MED USV Viewer manual and software version information.  
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CHAPTER 8  | USING MED-PC® INPUTS/OUTPUTS 
Follow the wiring instructions listed in the MED-PC® Controlled Operation section of this manual to 
connect the ANL-937-1 USV Detector to the MED-PC® inputs and outputs. MED-PC® can automatically 
control the start and stop of USV data acquisition to correspond to stimulus events within an operant 
chamber.  

One benefit of using the USV detector in conjunction with MED-PC® is that data can be viewed via the 
Med Associates SoftCR (SOF-721) or SoftCR Pro (SOF-722) Cumulative Recorder applications. The 
MedState Notation application titled ANL-937.mpc can be used to do this.  

Running the ANL-937.mpc Program in MED-PC® 

Programs written in MedState Notation must be compiled in Trans IV before they may be executed in 
MED-PC®. To compile a program, open Trans IV and click File > Open, select the ANL-937.mpc file in the 
Open file window and click Open. Now click the Make icon, see Figure 8-1, and Trans IV will compile the 
program for use in MED-PC®. If any problems are encountered during this process, refer to the on-
screen help menu or the MED-PC® User’s Manual, DOC-010, or contact Med Associates, Inc. for 
assistance. 

Figure 8-1 - Trans IV Make Icon 

 

 

After ANL-937.mpc is compiled open the USV detector application and set the data acquisition 
parameters, refer to Figure 5-1. Be certain that “Enable MED Input” is checked.  Click Browse, and in 
the “Experiment Name” window supply a file name and save to location, then click Save. Click the 
Update button to send the parameters to the ANL-937-1 and enable the Start button. 

Open MED-PC® and use the Experiment Loading Wizard to select the box(es) to load, adjust any 
program parameters and issue the start command. If the wizard does automatically open, click the 
wizard icon on the MED-PC® tool bar, see Figure 8-2. 

Figure 8-2 – Program Wizard Icon In the MED-PC® Tool Bar 
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Sample Data Fi le Created by ANL-937.mpc  

The ANL-937.mpc program creates a *.txt data file that can be viewed in any word processing program 
or spreadsheet. An example of a MED-PC® data file appears below with comments explaining the 
different sections and data values. 

File: D:\Program Files\MED Associates\MED-PC.new\DATA\!2005-07-07.Ss1 
 
Start Date: 07/07/10 
End Date: 07/07/10 
Subject: 1 
Experiment: 0 
Group: 0 
Box: 1 
Start Time:  9:29:00 
End Time:  9:32:22 
MSN: ANL_937 
B:       0.000 
E:       8.000 Total band 1 vocalizations above dB threshold value      
G:       6.000 Total band 2 vocalizations above dB threshold value 
H:       0.000    Not Used 
I:      44.000  Subscript that codes for the IRT Array C (for SoftCR)  
J:      16.000  Subscript for the Vocal Band 1, see Array D  
K:      12.000  Subscript for the Vocal Band 2, see Array E  
L:       0.000 Not Used 
M:       0.000 Not Used 
N:       0.000 Not Used 
O:       0.000 Not Used 
P:       0.000 Not Used 
Q:       0.000 Not Used 
R:       0.000 Not Used 
S:     180.010  Elapsed Time in Session 
T:    1720.000  Elapsed time in 0.01 second increments for SoftCR      
U:       0.000 Not Used 
V:       0.000 Not Used 
W:       0.000 Not Used 
X:       0.000 Not Used 
Y:       0.000  Counter for Vocal Band 1 Above Threshold 
Z:       0.000  Counter for Vocal Band 2 Above Threshold 

 
Array A includes the independent variables defined during the load wizard. 

A:   Acclimation time(seconds)   Session Length(minutes)   Using SoftCR?(Yes=1  No=0)  
  0:     3000.000                       3.000                      1.000 

 
Array C is used by SoftCR Pro and contains codes for event pens and the cumulative recorder. 
C: 
    0:     3149.100    0.600     580.110     0.610      116.500     116.510 
    6:     108.100     0.600     38.500      55.110     0.610       71.510 
    12:    179.100     0.600     2.110       0.610      410.500     295.510 
    18:    2410.100    0.600     188.110     0.610      352.500     10.510 
    24:    189.100     0.600     259.500     297.100    0.600       316.500 
    30:    501.110     0.610     2666.510    922.100    0.600       328.500 
    36:    1079.100    0.600     546.110     0.610      518.510     581.500 
    42:    1720.300    0.310 

 
Array D lists Band 1 On/Off Times.   
D: 
    0:     31.490     38.450    40.690       41.070       44.120       48.240 
    6:     75.290     80.690    82.680       85.270       88.240       91.400 
    12:    132.290    135.570   146.360      162.810 

 
 

Subject & session identifying information 
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Array F lists Band 2 On/Off Times. 
F: 
    0:     37.290     39.610    41.620       42.330       44.140       51.190 
    6:      77.170      80.790     96.410       123.070       151.820       157.000 

The SoftCR & SoftCR Pro Report  

The SoftCR or SoftCR Pro Cumulative Recorder can be used to graphically plot the data obtained from 
the ANL-937.mpc application. Refer to the SOF-721 SoftCR, DOC-034, or SOF-722 SoftCR Pro, DOC-204, 
users’ manuals for instruction on how to use these optional data utilities. Graphing parameters can be 
modified and the file can be saved as a *.pdf.  

 

Figure 8-3 – SoftCR Cumulative Record of Ultrasonic Events 

 

The ANL_937.mpc Program 

The entire program for integrating the USV Detector with MED-PC® is listed below. This information is 
included in the manual as a reference. Please make a backup copy of ANL-937.mpc so that if 
modifications are made to the code, an unadulterated copy will be available.  
\ Copyright (C) 2008 MED Associates, All rights reserved. 
 
\ ANL-937.mpc 
\ 
\ This example program demonstrates how to turn on the recording for the ANL-937 
\ microphone device and how to record the responses from the device. 
\ 
\ The Array's D and F contain the absolute times from when the program started 
\ that each event happened.  For example Array Element D(0) contains the first 
\ absolute time that the Band 1 Vocal went above its Threshold value.  Array 
\ Element D(1) contains the first absolute time that the Band 1 Vocal fell below 
\ its Threshold value.  Array Element D(2) contains the second absolute time 
\ that the Band 1 Vocal went above its Threshold value.  Array Element D(3) 
\ contains the second absolute time that the Band 1 Vocal fell below its 
\ Threshold value.  Etcetera. 
\ 
\ The Variables E and G contain the total number of times that each Vocal Band 
\ went above their respective Threshold values. 
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\ 
\ The Array C contains the same information as the Array's D and F and the 
\ Variables E and G, but it is recorded using the SoftCR data format.  SoftCR is 
\ an external program from MED-PC IV that can graph the data contained in Array C 
\ so that it may be more easily understood.  If SoftCR data is not desired, then 
\ just set the value in Array Element A(2) [ A(^SoftCR) ] to 0. 
\ 
\ SoftCR data is recorded in Relative Mode with a 10ms Resolution. 
\ 
\ The Input and Output constants listed below should be changed to match the 
\ existing hardware configuration.  The two Inputs need to be in Level Mode. 
\ Level Mode is set by selecting the appropriate Jumper or Switch (depending on 
\ the Input Card version) on the Input Card. 
 
 
\ Inputs 
^VocalBand1 = 1  \ Level Mode 
^VocalBand2 = 2  \ Level Mode 
 
\Outputs 
^StartRec = 1 
 
 
\ A() = Control Variables with Assigned Aliases as Defined 
Var_Alias Acclimation Time (sec)          = A(0)  \ Default = 60 seconds 
Var_Alias Session Length (min)            = A(1)  \ Default = 60 minutes 
Var_Alias SoftCR Data Array (Yes=1  No=0) = A(2)  \ Default = Yes 
 
\ Constants for Array A() 
^Acclim  = 0 
^Session = 1 
^SoftCR  = 2 
 
 
\ List Data Variables Here 
\  C() = IRT Array and Event Pen Code for Soft Cum. Recorder 
 
\  D() = Array of Band 1 On/Off Times 
\    D(0) = Time When Vocalization Went Above Band 1 Threshold 
\    D(1) = Time When Vocalization Went Below Band 1 Threshold 
\    D(2) = Time When Vocalization Went Above Band 1 Threshold 
\    D(3) = Time When Vocalization Went Below Band 1 Threshold 
\                                ... 
\    D(998) = Time When Vocalization Went Above Band 1 Threshold 
\    D(999) = Time When Vocalization Went Below Band 1 Threshold 
\  E = Total Band 1 Vocalizations 
 
\  F() = Array of Band 2 On/Off Times 
\    F(0) = Time When Vocalization Went Above Band 2 Threshold 
\    F(1) = Time When Vocalization Went Below Band 2 Threshold 
\    F(2) = Time When Vocalization Went Above Band 2 Threshold 
\    F(3) = Time When Vocalization Went Below Band 2 Threshold 
\                                ... 
\    F(998) = Time When Vocalization Went Above Band 2 Threshold 
\    F(999) = Time When Vocalization Went Below Band 2 Threshold 
\  G = Total Band 2 Vocalizations 
 
 
\ List Working Variables Here 
\  I = Subscript for the IRT Array C 
\  J = Subscript for the Vocal Band 1 Array D 
\  K = Subscript for the Vocal Band 2 Array E 
\  S = Elapsed Time in Session 
\  T = Elapsed Time in 0.01 sec Increments for SoftCR Data 
\  Y = Counter for Vocal Band 1 Above Threshold 
\  Z = Counter for Vocal Band 2 Above Threshold 
 
 
DIM A = 2 
DIM C = 10000 
DIM D = 1000 
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DIM F = 1000 
 
\ Z-Pulses Used in this Program 
^StartRec  = 1   \ Z1  = Start Recording 
^Vocal1On  = 2   \ Z2  = Signal Vocal 1 Above Threshold 
^Vocal1Off = 3   \ Z3  = Signal Vocal 1 Below Threshold 
^Vocal2On  = 4   \ Z4  = Signal Vocal 2 Above Threshold 
^Vocal2Off = 5   \ Z5  = Signal Vocal 2 Below Threshold 
^EndSess   = 32  \ Z32 = End of Session Signal 
 
 
DISKCOLUMNS = 6 
 
\*************************************************** 
\                 ANL-937 Schedule 
\  S1 - Set Default Values 
\          Acclimation Time  (60 seconds) 
\          Session Length    (60 minutes) 
\          SoftCR Activation (1-Yes) 
\*************************************************** 
S.S.1, 
S1, 
  0.001": SET A(^Acclim) = 60, A(^Session) = 60, A(^SoftCR) = 1 ---> S2 
 
S2,     \ First Statement: Wait for START signal. 
        \ 
        \ Second Statement: Update screen display with default values 
        \ for control variables.  This will show any changes made via 
        \ the "Configure | Change Variables" Window prior to START. 
  #START: CLEAR 1,60; SET A(^Acclim) = A(^Acclim) * 1" ---> S3 
  1": SHOW 1,Acclim Time,A(^Acclim), 2,Session Length,A(^Session), 3,SoftCR Code,A(^SoftCR) ---> 
SX 
 
S3,     \ Time Acclimation Period. 
        \ Turn on Recording Output and Signal 
        \ that Recording has Started. 
  A(^Acclim)#T: SHOW 2,Total Band 1,E, 3,Total Band 2,G; 
                ON ^StartRec; Z^StartRec ---> S4 
 
S4, 
  1': ---> SX 
 
\*************************************************** 
\            RECORD RESPONSES FOR BAND 1 
\*************************************************** 
S.S.3, 
S1,     \ Wait for Acclimation Period to End. 
  #Z^StartRec: ---> S2 
 
S2,     \ Record the Absolute Time that the Vocal 
        \ Band 1 went above its Threshold and the 
        \ Total Number of Responses on Vocal Band 1. 
  #Z^EndSess: ---> S4 
  #Z^Vocal1On: SET D(J) = S, J = J + 1, D(J) = -987.987; 
               ADD E; SHOW 2,Total Band 1,E ---> S3 
 
S3,     \ Record the Absolute Time that the Vocal 
        \ Band 1 went below its Threshold. 
  #Z^EndSess: ---> S4 
  #Z^Vocal1Off: SET D(J) = S, J = J + 1, D(J) = -987.987 ---> S2 
 
S4,     \ Holding State at End of Session 
  1': ---> SX 
 
 
\*************************************************** 
\            RECORD RESPONSES FOR BAND 2 
\*************************************************** 
S.S.5, 
S1,     \ Wait for Acclimation Period to End. 
  #Z^StartRec: ---> S2 
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S2,     \ Record the Absolute Time that the Vocal 
        \ Band 2 went above its Threshold and the 
        \ Total Number of Responses on Vocal Band 2. 
  #Z^EndSess: ---> S4 
  #Z^Vocal2On: SET F(K) = S, K = K + 1, F(K) = -987.987; 
               ADD G; SHOW 3,Total Band 2,G ---> S3 
 
S3,     \ Record the Absolute Time that the Vocal 
        \ Band 2 went below its Threshold. 
  #Z^EndSess: ---> S4 
  #Z^Vocal2Off: SET F(K) = S, K = K + 1, F(K) = -987.987 ---> S2 
 
S4,     \ Holding State at End of Session 
  1': ---> SX 
 
\*************************************************** 
\  VOCAL BAND 1 THRESHOLD - 20ms ABOVE, 20ms BELOW 
\*************************************************** 
S.S.7,  \ Vocal Band 1 Threshold - 20ms Above, 20ms Below. 
S1,     \ Inputs in Level Mode generate an Input "count" on each 
        \ Interrupt.  With a 10ms system Resolution 2 counts 
        \ will be reached in 20ms.  The Z^Vocal1On pulse is used 
        \ to signal that it is above its Threshold.  The second 
        \ statement resets the counter every 20 ms so that false 
        \ readings less than 20ms will not constitute a response. 
  #R^VocalBand1: ADD Y; IF Y >= 2 [@AboveThreshold, @FalseReading] 
                           @Above: Z^Vocal1On; SET Y = 0 ---> S2 
                           @False: ---> SX 
  0.02": SET Y = 0 ---> S1 
 
S2,     \ As long as the Vocal 1 level is above its Threshold 
        \ the second statement causes a re-entry to this State. 
        \ This resets the the internal 20ms Timer so it never 
        \ times out.  When the level falls below the Threshold 
        \ in Band 1 for 20ms the Timer times out and a 
        \ Z^Vocal1Off pulse signals the release of the event. 
  0.02": Z^Vocal1Off ---> S1 
  #R^VocalBand1: ---> S2 
 
\*************************************************** 
\  VOCAL BAND 2 THRESHOLD - 20ms ABOVE, 20ms BELOW 
\*************************************************** 
S.S.9, 
S1, 
  #R^VocalBand2: ADD Z; IF Z >= 2 [@AboveThreshold, @FalseReading] 
                           @Above: Z^Vocal2On; SET Z = 0 ---> S2 
                           @False: ---> SX 
  0.02": SET Z = 0 ---> S1 
 
S2, 
  0.02": Z^Vocal2Off ---> S1 
  #R^VocalBand2: ---> S2 
 
 
\*************************************************** 
\     INCREMENT TIME T FOR IRT AND EVENT ARRAY 
\*************************************************** 
S.S.11, 
S1, 
  #START: IF A(^SoftCR) > 0 [] ---> S2 
 
S2, 
  0.01": ADD T ---> SX 
  #Z32: ---> S1 
 
 
\**************************************************************** 
\ ADD A STEP 0 ELEMENT TO ARRAY C FOR EACH VOCAL BAND 1 RESPONSE 
\**************************************************************** 
S.S.13, 
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S1, 
  #Z^StartRec: IF A(^SoftCR) > 0 [] ---> S2 
 
S2,     \ Vocal 1 Response above its Threshold 
  #Z^EndSess: ---> S1 
  #Z^Vocal1On: SET C(I) = T + 0.10, T = 0; ADD I; 
               IF I = 10000 [@True, @False] 
                  @True: ---> S1 
                  @False: SET C(I) = -987.987 ---> SX 
 
 
\**************************************************************** 
\ ADD A STEP 1 ELEMENT TO ARRAY C FOR EACH VOCAL BAND 2 RESPONSE 
\**************************************************************** 
S.S.15, 
S1, 
  #Z^StartRec: IF A(^SoftCR) > 0 [] ---> S2 
 
S2,     \ Vocal 1 Response above its Threshold 
  #Z^EndSess: ---> S1 
  #Z^Vocal2On: SET C(I) = T + 0.11, T = 0; ADD I; 
               IF I = 10000 [@True, @False] 
                  @True: ---> S1 
                  @False: SET C(I) = -987.987 ---> SX 
 
 
\************************************************************* 
\ RAISE THE EVENT 0 ELEMENT IN ARRAY C FOR THE LENGTH OF TIME 
\         THAT VOCAL BAND 1 IS ABOVE ITS THRESHOLD 
\************************************************************* 
S.S.17, 
S1, 
  #Z^StartRec: IF A(^SoftCR) > 0 [] ---> S2 
 
S2,     \ Raise the Event 0 Element 
  #Z^EndSess: ---> S1 
  #Z^Vocal1On: SET C(I) = T + 0.60, T = 0, I = I + 1; 
               IF I >= 10000 [@True, @False] 
                  @True: ---> S1 
                  @False: SET C(I) = -987.987 ---> S3 
 
S3,     \ Lower the Event 0 Element 
  #Z^EndSess: ---> S1 
  #Z^Vocal1Off: SET C(I) = T + 0.50, T = 0, I = I + 1; 
                IF I >= 10000 [@True, @False] 
                   @True: ---> S1 
                   @False: SET C(I) = -987.987 ---> S2 
 
\************************************************************* 
\ RAISE THE EVENT 1 ELEMENT IN ARRAY C FOR THE LENGTH OF TIME 
\         THAT VOCAL BAND 2 IS ABOVE ITS THRESHOLD 
\************************************************************* 
S.S.19, 
S1, 
  #Z^StartRec: IF A(^SoftCR) > 0 [@ActivateSoftCR, @NoSoftCR] 
                  @ActSoftCR: ---> S2 
                  @NoSoftCR: SET C(0) = -987.987 ---> SX  \ Seal Array 
 
S2,     \ Raise the Event 1 Element 
  #Z^EndSess: ---> S1 
  #Z^Vocal2On: SET C(I) = T + 0.61, T = 0, I = I + 1; 
               IF I >= 10000 [@True, @False] 
                  @True: ---> S1 
                  @False: SET C(I) = -987.987 ---> S3 
 
S3,     \ Lower the Event 1 Element 
  #Z^EndSess: ---> S1 
  #Z^Vocal2Off: SET C(I) = T + 0.51, T = 0, I = I + 1; 
                IF I >= 10000 [@True, @False] 
                   @True: ---> S1 
                   @False: SET C(I) = -987.987 ---> S2 
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\********************************************* 
\                SESSION CLOCK 
\********************************************* 
S.S.21, 
S1, 
  #START: SHOW 1,Session,S/60 ---> S2 
 
S2, 
  0.01": SET S = S + 0.01; SHOW 1,Session,S/60; 
         IF S/60 >= A(^Session) [@EndSession, @ContinueTiming] 
            @End: SET C(I) = T + 0.30, C(I+1) = 0.31; 
                  SET I = I + 2, C(I) = -987.987; 
                  OFF ^StartRec; Z^EndSess ---> S3 
            @Cont: ---> SX 
 
S3,     \ Wait for Screen Update and end with 
        \ STOPABORTFLUSH for Automatic Data Saving 
  2": ---> STOPABORTFLUSH 
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Appendix A| CONTACT INFORMATION 
Please contact Med Associates, Inc. for information regarding any of our products.   

Visit our website at www.med-associates.com for contact information. 

For technical questions, please call 802-527-2343 or email support@med-associates.com. 

 

http://www.razelscientific.com/
http://www.med-associates.com/contact.htm
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