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CHAPTER 1  | OVERVIEW 

The SOF-737 MED-PC® software package contains four separate applications: MED Test, the 

Hardware Configuration Utility, Trans and MED-PC®. 

MED Test: MED Test helps verify hardware functionality independently of MED-PC®.  This 

includes an interface card test, Programmable Audio Generator (ANL-926) test, and tests for 

SmartCtrl™ interface modules, Standard modules, SuperPort™, OmniCard modules and more. 

Hardware Configuration Utility (HCU): The HCU is used to build a configuration file that informs 

MED-PC® how many boxes are connected, how many inputs and outputs are available to each 

box, and how are they identified.  The utility includes on-screen guides that walk the user step 

by step through the set-up procedure. 

Trans: Trans is used to compile MedState Notation™ (MSN) procedures into DLL files that may 

be executed by MED-PC®.  Trans also serves as a text editor for writing MSN procedures and 

includes a detailed help file related to MSN programming. 

MED-PC®: MED-PC® is the runtime or operating system in which MSN procedures are executed.  

It allows for the use of up to 16 test chambers with up to one million data elements per 

chamber.  A single test chamber may have up to 80 inputs and 80 outputs. 

General Computer Environment 

MED-PC® systems require a PC running Windows 7 64 bit (or later) with at least one USB slot if 

using a DIG-705 or a full height PCI slot for a or a full height PCI-Express slot for a DIG-704. 

 

To use the new OmniCard hardware with MED-PC VI a DIG-705 USB must be used. 
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CHAPTER 2  | SOFTWARE INSTALLATION 

If the computer was purchased as part of a complete MED-PC® system from MED Associates, 
the driver and software installation was completed at the factory, please proceed to Chapter 3, 
Hardware Setup.  If the computer was not purchased from MED Associates as part of a system, 
or MED-PC® is being reinstalled for another reason, follow the instructions below to install the 
drivers and software. 
 
Before beginning the software installation, please phone, fax or e-mail MED Associates with 
the registration information in order to receive the software installation password.  This 
password will be necessary during the software installation process. 
 
Insert the MED-PC® USB stick into a USB slot and at the welcome screen click Install MED-PC VI.  

If the install does not auto-start, navigate to the USB stick in Windows Explorer and double click 

"Autorun.exe" and click Install MED-PC VI at the welcome screen.  Successful installation of 

each component will be indicated by a green check mark, a red X will indicate an unsuccessful 

installation.  When prompted enter the user name, company name and software installation 

password.  When the installation completes, click Finish. 

Once MED-PC® is installed please install any other MED Associates, Inc. software that is going to 

be used in a similar manner. 
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CHAPTER 3  | QUICK START GUIDE 

New systems purchased from MED Associates will have the required software installed on the 

PC, the DIG-705 USB card installed in the interface cabinet, the hardware connections will be 

pre-configured and include instructions for completing the hardware setup.  Please refer to the 

included instructions to complete the hardware set up. 

The quick start steps should be performed after MED-PC® and any other related software has 

been installed, please see Chapter 2, Software Installation. 

The following quick start guide is designed to get the user up and running using a single 

interface cabinet (rack) and OmniCard modules, where each OmniCard module is assigned to an 

individual chamber.  For more involved installations please see Chapter 6, Advanced 

Installations.  Before proceeding, please refer to the documentation included with the interface 

cabinet and OmniCard modules to ensure the hardware is connected properly, and that the 

OmniCard modules have the correct address and offset settings. 

DIG-705 USB Connection 

Connect the DIG-705 USB to any available USB port on the computer. 

Hardware Configuration 

In order to use MED-PC® it is necessary to complete the hardware configuration.  The Hardware 

Configuration Utility (HCU) may be accessed at any time when adding or removing hardware to 

or from a system. 

If the computer was purchased from MED Associates, Inc. as part of a system, the hardware 

configuration has already been completed.  The Hardware Summary may be viewed or printed 

to review the current settings.  Do not change the number of boxes or specific input and output 

definitions unless additional boxes or different interface cards have been added to the interface. 

Setting Rack Size 

Upon opening the HCU, the screen presents a view of the interface cabinet (Figure 3-1).  Click 

Adjust Rack Size to set the appropriate rack size being used, 8 or 17 slots (DIG-704 only).  This 

sets the number of locations available for use with different interface cards, not including the 

slots used by the Decode card or power switch locations. 

If a DIG-705, SG-7000 series interface cabinet and OmniCard modules are being used, 

then the HCU will automatically detect the cards in the interface cabinet , set the rack 

size, and pre-populate the screen. 
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Figure 3-1 - Hardware Configuration – Adjust Rack Size 

 

Adding OmniCard Modules 

OmniCard modules may be added to the hardware configuration one at a time or in groups.  To 

add a single card click Add Card (Figure 3-1) in the desired card location to open the Add Card 

window (Figure 3-2).  Select the desired card and the Input Port, Output Port and Offset 

information will be automatically populated.  Click OK to add the card to the rack.  Repeat these 

steps until all desired cards have been added. 
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Figure 3-2 - Add Card Window 

 

 

To insert multiple cards of the same type at the same time, click Add Multiple Cards of the 

Same Model (Figure 3-1) to open the Add Multiple Cards of the Same Model window.  Use the 

drop-down menus to select the card model and number of cards to add (Figure 3-3) and click OK 

to add the cards to the rack. 

Figure 3-3 - Add Multiple Cards of the Same Model  
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Figure 3-4 - HCU With Four OmniCard Modules 

 

 

When adding cards to the rack, keep in mind that the card mapping steps to follow will be easier 

to perform if like cards are grouped together in the rack. 

When adding a single card (Figure 3-2), the Other option in the Add Card window is used to add 

cards that are not listed, such as the ANL-926 Programmable Audio Generator. 

 

With OmniCard modules the automatic port and offset settings are assigned sequentially based 

on the card's physical location in the rack.  If the desired port and offset settings differ from this 

convention, click Edit Address (Figure 3-4) on each card to adjust the port and offset values to 

match the physical switch/jumper settings on the card. 

The OmniCard module has the unique ability to have each I/O be either an input or output.  By 

default, all I/O's will be an input.  To change this first click on Edit Address and then on Define 

I/O Channels (Figure 3-5). 
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Figure 3-5 - Edit Address 

 

 

To change an I/O to Output just select the appropriate radio button or click on the button that 

says All Outputs to change all the I/Os in that column. 

Figure 3-6 – Configure I/O Channels 

 

 

Once the inputs and outputs are all set the configuration can be copied to the other cards by 

clicking on the button that says Copy I/O Channels (Figure 3-5). 
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Card Mapping 

After the cards have been added to the rack, their inputs and outputs need to be mapped to the 

chambers.  Interface cards may be assigned to individual chambers, or inputs and outputs may 

be spread across different chambers.  See Chapter 6, Alternative Installations for mapping 

inputs or outputs across multiple chambers. 

Click the Auto Map SmartCtrl and OmniCard Modules button (Figure 3-4) or click Tools > Auto 

Map SmartCtrl and OmniCard Module… to open the SmartCtrl or OmniCard Auto Mapping 

window (Figure 3-7) and see how the cards will be allocated across the chambers.  Click OK to 

map the cards and the Hardware Summary (Figure 3-8) will open so that the inputs and outputs 

may be reviewed.  Click the Close button to exit the Hardware Summary.  Close the HCU and 

select Yes when prompted to save the hardware configuration. 

Figure 3-7 - Auto Mapping 
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Figure 3-8 - Hardware Summary 

 

Temporal Resolution 

The recommended Temporal Resolution is 10 milliseconds (ms).  All timed values will be based 

on a multiple of the value of the Temporal Resolution.  To set the Temporal Resolution click 

Tools > Temporal Resolution… and select the 1 ms or 10 ms radio button. 

After selecting the Temporal Resolution (Figure 3-9), click OK to continue and exit the HCU, click 

Yes to save the changes if prompted. 

http://www.razelscientific.com/


MED ASSOCI ATES,  I NC.  SOF-737 MED-PC® 

 

- 10 - 

DOC-335 Rev 1.0 Copyright © 2023 

MED Associates, Inc. 

Figure 3-9 - Temporal Resolution 

 

 

Multiple Hardware Configurations 

It is possible to save multiple hardware configurations for use under different circumstances or 

by different users.  After completing the hardware configuration steps outlined above, click File 

> Save As… and provide a meaningful file name for the hardware configuration. 

Hardware Summary 

The hardware configuration summary (Figure 3-8) may be viewed or printed at any time by 

clicking the Hardware Summary button or by clicking Tools > Hardware Summary… A printed 

summary is available by clicking the Print button in the hardware summary screen or by clicking 

File > Print Hardware Summary. 

Data File Options 

In previous versions of MED-PC® the data file options were handled from within the Hardware 

Configuration Utility.  The data file options are now set from within MED-PC® VI itself. 

The recommend data file options are shown in Figure 3-10.  Access the data file options in MED-

PC® by clicking Data > File Options…These options and the different data file formats are 

explained in detail in Chapter 7, Data File Formats. 
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Figure 3-10 - Data File Options 

 

 

MED-PC®, the rack and OmniCard modules are now ready to use.  For more advanced options 

and sharing inputs and outputs across multiple chambers see Chapter 6, Advanced Installations. 
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CHAPTER 4  | RUNNING A MED-PC® PROCEDURE 

This chapter is designed to be an introduction to some of the features of the MED-PC® interface.  

More in-depth information is available via the on-screen help which is accessed by clicking Help 

> Help for MED-PC, pressing the F1 key or clicking the Help (question mark) toolbar button. 

Before a procedure may be executed in MED-PC®, it must be compiled in Trans.  If a compiled 

procedure does not yet exist, please refer to DOC-301, MED-PC® Programmer's Manual for an 

overview of MedState Notation and follow the steps in Tutorial #1 to create a procedure and 

compile it in Trans. 

To use an existing procedure from a previous version of MED-PC®, copy the *filename*.mpc file 

to the "C:\MED-PC\MPC" folder and compile it in Trans. 

Loading a Procedure Using the Experiment Loading Wizard 

In MED-PC® click the Wizard button (Figure 4-1) or click Sessions > Wizard for Loading Boxes 

and the Experiment Loading Wizard will appear (Figure 4-2).  Select the box(es) to load and click 

Next. 

Figure 4-1 - Experiment Loading Wizard Button 

 

Figure 4-2 - MED-PC® Experiment Loading Wizard 
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Select the procedure to load (Figure 4-3) and click Next. 

If there are compiled MedState Notation (MSN) programs ready to run in the MPC folder, the 

Experiment Loading Wizard will automatically start when MED-PC® is opened.  To disable this 

feature, in the Start Boxes screen (Figure 4-2) clear the check box in the lower left corner of the 

screen. 

 

Figure 4-3 - Select Procedure to Load 

 

 

Enter any desired procedure information (Figure 4-4) and click Load. 
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Figure 4-4 - Procedure Information Screen 

 

At this point if the procedure employs any control variables via VAR_ALIAS commands, the 

session parameters screen (Figure 4-5) will open allowing for adjustment to the control 

variables.  Click Accept Parameters when ready to proceed. 

Figure 4-5 - Session Parameter Adjustments Screen  
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To issue a start signal to the currently loaded box(es) and exit the wizard, tick the check box next 

to each desired loaded box and click Finish.  The wizard will close and the MED-PC® runtime 

screen (Figure 4-7) will be displayed. 

To issue a start signal to the currently loaded box(es) and then load additional boxes, tick the 

check box next to each desired loaded box and click the Load another box button.  The selected 

boxes will begin to run and the Experiment Loading Wizard will begin again starting with the 

image in Figure 4-2. 

To load more boxes without starting the currently loaded boxes, click the Load another box 

button and step through the wizard again. 

 

Figure 4-6 - Start Boxes Screen 
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Figure 4-7 - MED-PC® Runtime Screen 

 

Loading a Procedure Manually 

To load one or more boxes, click Sessions > Load Box…, type Ctrl+O, or click the Load Box icon 

(Figure 4-8) from the toolbar to open the Load Box screen. 

Figure 4-8 - Load Box Icon 

 

 

In the Load Box screen (Figure 4-9) select the box(es) to load using the check boxes in the Load? 

column, select the procedure to load from the Procedure dropdown and add any desired subject 

and experiment information and comments. 
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Figure 4-9 - Load Box Screen 

 

 

Clicking Apply will load the procedure(s) into the selected box(es) and keep the Load Box screen 

open to load other boxes.  Clicking OK will load the procedures and then close the Load Box 

screen. 

Issuing a Start Command 

The fastest way to issue a start command to a single loaded box is to select the box in the Box 

Status window and click the Issue Start Signal to Selected Box button in the tool bar (Figure 

4-10).  Please note, not all MedState Notation programs require or accept a Start command. 

Figure 4-10 - Issue Start Signal to Selected Box  

 

 

A single box may also be started by clicking the corresponding box slide out tab (red arrow, 

Figure 4-11) to reveal that box's activity screen, and then clicking the Issue Start Signal to 

Selected Box button (blue arrow, Figure 4-11) in that box's toolbar. 

Figure 4-11 - Slide Out Box Activity Screen 
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Single or multiple boxes may be started at the same time by clicking Sessions > Signals (Start, 

#K, #R)… or by clicking the Send K, R or Start Signal button in the toolbar (Figure 4-12) to open 

the Send Signals to Boxes screen in Figure 4-13. 

Figure 4-12 - Send K, R, or Start Signal Button 

 

 

Use the radio buttons and check boxes to select the type of signal to send, which box(es) to 

send the signal to and then click Apply to send the signal and keep the Send Signals to Boxes 

screen open or click OK to send the signal and close the Send Signals to Boxes screen.  When 

sending a simulated response (#R) or K pulse, use the drop downs to set which input number the 

response is simulating, or which K pulse is being issued. 

Figure 4-13 - Send Signals to Boxes 

 

 

Stopping a Procedure 

If a procedure needs to be stopped manually click Sessions > Stop Box… or click the Stop 

button.  In the Stop Boxes window select whether to save or abandon the data, click which 

box(es) to stop and click OK.  See Figure 4-14. 
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Figure 4-14 - MED-PC® Stop Button and Stop Boxes Window 
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CHAPTER 5  | USER INTERFACE 

Sessions Menu 

 

 Load Box – Ctrl+O Opens the Load Box window to select and load procedures into 

boxes and enter session information. 

 Modify Identifiers Opens the Modify Session Identifiers window to enter or alter 

session information such as the subject, experiment, group and 

add comments. 

 

Wizard for Loading 

Boxes 

Opens the Experiment Loading Wizard to walk the user through 

loading procedures into boxes and begin a session. 

 

Stop Box Opens the Stop Boxes window to stop a procedure in one or 

more boxes. 

 
Change Variables – 

Ctrl+A 

Opens the Change Variables screen to modify procedure 

variable and array values. 

 

Signals (Start, #K, 

#R) 

Opens the Send Signals to Boxes screen to issue start 

commands or send simulated responses and K pulses to 

selected boxes. 

 

Outputs Opens the Outputs screen to turn outputs on or off, lock 

outputs on or off or turn an output on for a specified duration. 

 Beep When All 

Sessions Are 

Finished 

When all sessions in all boxes are completed the computer will 

issue a tone. 

 Shut Off Beeping Turns off the sessions ended tone. 

 Exit Exits MED-PC® 

 Exit When All 

Sessions Are 

Finished 

Closes MED-PC® when all sessions finish running. 

 

Data Menu 

 
Print – Ctrl+P Opens the Boxes to Print screen.  From here it is possible to print 

the data as it stands from any currently running box. 

 Form Feed Sends a form feed command to the default printer. 

 Printer Selection Opens the Printer Selection screen to set the default printer. 
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 Printout Settings Opens the printer settings screen to set default printout settings. 

 File Options Opens the Data File Options screen to select the data file format, 

naming convention, data directory location and automatic 

backup time interval. 

 

View Menu 

 Desktops Click to save the current desktop layout, delete a desktop view 

or switch to a saved desktop view.  The Desktop dropdown on 

the toolbar may also be used to switch between saved desktops. 

 Float Box Panels By default the box panels are pinned to the right side of the 

screen (red arrow, Figure 4-11).  When using one monitor this 

menu lets the user float the box panels outside the main MED-

PC® interface.  When using two monitors the box panels may be 

assigned to a single monitor or split across the two monitors. 

 Pin Box Panels to 

Right 

Closes and pins the box panels to the right side of the screen.  

Hover over or click a box panel tab to open that box's panel. 

 Place Box Panels 

into Notebook 

Presents the box panels in a tabbed notebook format on the 

right side of the screen. 

 Panel Visibility Lets the user select which panels are visible. 

 

Display Log Opens the log dialog screen to enable opening other log files, 

printing log files and searching within log files. 

 Reset Error 

Indicator 

Clears the error warning in the status bar at the bottom of the 

MED-PC® run time screen. 

 State Sets Opens the active state within each stateset screen to view the 

state that each stateset is currently in for the selected box. 

 System 

Performance 

Presents information about MED-PC® cycle times. 

 

Macros Menu 

 
Play Macro – F5 Opens the macro selection screen to select and run a macro. 

 
Record Macro – F6 Click to begin recording a new macro. 

 Insert Macro 

Playback Delay 

Inserts a user specified delay in the macro playback.  The delay is 

in milliseconds. 
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 Editor Opens the macro editor to create a new macro or edit an 

existing macro. 

 
Stop Recording – F6 Enabled while recording a macro, select to stop macro recording. 

   

   

 Assign Macros to 

Shortcut Key 

Combinations 

Opens the Macro Shortcut Assignment window to assign macros 

to keyboard shortcuts. 

 Configure Macro 

Shortlist Button 

Opens the Configure Macro Shortlist Button screen to add or 

remove macros to or from the Shortlist Macros dropdown list on 

the toolbar. 

 Configure Context-

Dependent Macros 

Opens the Configure Context Dependent Macros screen to 

assign macros to a program.  When that program is loaded, the 

assigned macros are now available in the Context Macros 

dropdown list on the toolbar. 

 

Settings Menu 

 Edit Procedure List Used to create a list of procedures that will be displayed when 

loading boxes.  Each Windows user can create their own list as a 

way to display only the procedures that are of interest to them. 

 Autohide Box Panel 

Toolbars 

Hides the box panel toolbars when not in use.  The toolbars 

automatically appear when the mouse is placed over either the 

status area of the box panel or over the bottom grid where show 

command output is displayed. 

 Enable Tooltips Turn tooltips on or off. 

 Hardware 

Configuration 

Opens the hardware configuration utility. 

 

Help Menu 

 

Help for MED-PC – 

F1 

Opens the MED-PC® help screen.  The on-screen MED-PC® help 

covers more topics in greater detail. 

 Help for Trans Opens the Trans help screen.  The on-screen Trans help covers 

more topics in greater detail. 

   

http://www.razelscientific.com/


MED ASSOCI ATES,  I NC.  SOF-737 MED-PC® 

 

- 23 - 

DOC-335 Rev 1.0 Copyright © 2023 

MED Associates, Inc. 

 About Provides the MED-PC® version, build and release number 

information as well as copyright information. 

 

Other Toolbar Buttons 

The following buttons are not included in the menu items discussed above. 

 
Issue Start 

Signal to 

Selected Box 

Sends a start command to the box currently 

selected in the Box Status window or the active 

floating box panel. 

 
Macros Shortlist A dropdown list of macros that have been 

assigned to the macro shortlist. 

 
Context Macros 

List 

If a loaded procedure has macros assigned to it, 

these macros will be available via this dropdown 

list. 

 
Desktop 

Dropdown List  

A dropdown list of available saved desktops. 

 
Save Desktop Opens a window to save the current desktop 

layout. 

 

Inputs and Outputs Panels 

The Inputs and Outputs panels allow the user to simulate inputs and outputs through MED-PC®.  

To simulate an input or output, double click in the square (red arrow, Figure 5-1) under the 

desired input or output number, in the row of the desired chamber.  This feature is helpful when 

writing and debugging MedState Notation (MSN) code. 

Inputs happen momentarily and outputs must be double clicked again to be turned off. 

Figure 5-1 - Inputs and Outputs Panels  

 

 

Double click the input or output number in the top row to affect that numbered input/output in 

all chambers. 
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Right click the input number in the top row, or individual input box, to simulate a level mode 

input.  See the user's manual for the type of input card being used for more information on level 

versus toggle mode inputs. 

Show Command Output Panel 

The Show Command Output panel, Figure 5-2, displays the information represented by the 

SHOW commands in the MSN code.  Figure 5-3 explains the controls in the Show Command 

Output panel. 

Figure 5-2 - Show Command Output Panel 

 

 

Figure 5-3 - Show Command Output Options 

 
Cycles through the box displays in decreasing (<) or increasing 

(>) order.  Clicking All will display all of the boxes. 

 
Automatically cycles through all running boxes until pressed 

again. 

 
Pressing = will adjust all columns to an equal width.  Pressing ≠ 

adjusts the columns to fit their largest content. 

 

Increases or decreases the number of columns displayed.  Type 

in the desired number of columns or use the up and down 

arrows to set the number of columns. 

 
Increases or decreases the number of show rows displayed for 

each box.  1 – 40 rows are available per box. 

 

Box Panel Tabs 

Box panels allow the user to interact directly with one selected box (chamber) at a time.  By 

default, the box panels are pinned to the upper right corner of the user interface, see Figure 5-4.  

Hovering over a box's tab will temporarily slide open the selected box's panel to reveal that 
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box's status panel, inputs and outputs panel, show command output panel and toolbar, see 

Figure 5-5. 

Figure 5-4 - Pinned Box Panel Tabs 

 

 

Figure 5-5 - Box One's Panel 

 

 

Once the cursor is removed from the box's panel or tab, the panel will slide closed.  To open a 

box's panel and keep it open, click on the desired box's panel tab.  To close the panel after 

clicking it open, hover over, or click on another box's panel tab. 
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Docking Panels 

The MED-PC® user interface contains customizable panels.  Each panel can be resized, 

repositioned and some panels can be designated to float outside the main user interface.  The 

red bars in Figure 5-6 indicate the resizing bars.  Click and drag any of these bars to resize the 

individual panels. 

Figure 5-6 - Panel Resize Bars 

 

 

Each panel in the interface may also be repositioned by clicking and holding on the panel's title 

bar and dragging the panel to a new location.  When the panel begins to move "guide points" 

will appear at the top, bottom, left and right edges of the screen.  Guide points will also appear 

in the panel in which the mouse pointer is located.  These guide points indicate where the panel 

will be positioned if the mouse pointer is released over that particular guide point. 

Figure 5-7 - Guide Point for Panel Placement  

 

In Figure 5-8 the Outputs panel title bar has been clicked and held while the mouse has been 

moved up to the Box Status panel window.  The edge of screen guide points, circled in red in 

Figure 5-8, would pin the Outputs panel to the top, bottom, right or left of the screen.  While it 

is not displayed in the image, the mouse is actually positioned over the bottom guide point, red 

arrow Figure 5-8, and the shaded area indicates where the panel will be positioned. 
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Figure 5-8 - Panel Locating Guide Points 

 

 

Notice in Figure 5-9 that the Outputs panel is now located under the Box Status panel as 

indicated by the shaded area in Figure 5-8 before the mouse was released. 

Figure 5-9 - Repositioned Outputs Panel 
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CHAPTER 6  | ALTERNATIVE INSTALLATIONS 

It is not uncommon for a MED-PC® system to use more than just OmniCard modules.  This 

section will describe how to set up a MED-PC® system that uses a SuperPort card in addition to 

OmniCard modules.  It will also explain how to allocate inputs across multiple chambers.  For 

this example, we will use 3 IC-124 OmniCard modules, 1 assigned to each chamber, and 1 DIG-

713A SuperPort input card, sharing its inputs across the 3 chambers. 

When using different card types, the input/output mapping steps to follow are easier to perform 

if identical card types are grouped together in the rack.  For this reason, we will add the 3 IC-124 

OmniCard modules, and then add the DIG-713A SuperPort card. 

As explained in Chapter 3 Adding OmniCard Modules, click Add Multiple Cards of the Same 

Model, Select IC-124 OmniCard from the Card Model drop down list, select 3 from the Number 

of Cards to Add drop down and click the OK button. 

Click on Edit Address and then on Define I/O Channels and set the number of inputs to be 8 and 

the number of outputs to be 16 (Figure 3-6 – Configure I/O Channels). 

To automatically assign all inputs and outputs in sequential order for the IC-124s, click the Auto 

Map SmartCtrl and OmniCard Modules button (Figure 3-4) or click Tools > Auto Map SmartCtrl 

and OmniCard Module… Click the OK button to accept the auto-map, review the hardware 

summary that opens, and click the Close button. 

In the fourth slot of the rack click the Add Card link, select DIG-713A SuperPort Input from the 

card model list and click the OK button to accept the default input port and offset values. 

At this point there are two approaches that can be used for mapping the DIG-713A's inputs.  To 

start, click the Auto Map All Cards button or click Tools > Auto Map All Cards… to open the 

Rapid Input/Output Mapping for All Modules window.  Select 3 for the number of boxes 

(chambers) being used from the drop down and the HCU will, by default, evenly distribute (if 

possible) the available inputs and outputs across all of the boxes, see Figure 6-1.  Click OK to 

accept the default, sequentially allocated inputs and outputs and open the Hardware Summary 

screen in Figure 6-2. 
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Figure 6-1 - Rapid Input/Output Mapping 

 

 

Review the Hardware Summary screen carefully as this approach will assign the inputs and 

outputs in sequential order, and this is not the desired result for this example.  Notice in Figure 

6-2 that inputs 9 – 13 in box 1 are actually inputs 1 – 5 from the second OmniCard module, not 

inputs from the DIG-713A. 

If this Hardware Summary was what we desired, we would click Close to close the summary and 

then close the HCU and select Yes when prompted to save the hardware configuration. 
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Figure 6-2 - Hardware Summary Using Auto Map All Cards  

 

 

However, the default assignments are not the desired result of sharing the DIG-713A's inputs 

across the 3 chambers, so we will use the second approach to assigning inputs and outputs after 

closing the summary. 

After auto-assigning the three OmniCard modules to boxes 1 – 3 using the Auto Map SmartCtrl 

and OmniCard Modules button as described above, click the Map to Boxes link on the DIG-713A 

SuperPort input card (Figure 6-3) to open the Map to Boxes screen (Figure 6-4) to manually 

assign the DIG-713A's inputs across the different chambers. 
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Figure 6-3 - Three IC-124 and one DIG-713A Cards Installed 

 

Figure 6-4 - Map to Boxes Window 
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The left three radio buttons in the Map to Boxes screen handle assigning inputs, the right three 

radio buttons assign the outputs. 

The DIG-713A has 16 inputs, and for this example we will assign five inputs to each of the three 

chambers.  These will become inputs 9 -13 for each chamber.  Click the second radio button and 

enter Assign 5 inputs per box.  Start with box 1 and end with box 3 and click the Assign button, 

see Figure 6-5. 

Figure 6-5 - Assigning Inputs to Chambers 

 

 

Figure 6-7 shows two images of the lower portion of the Map to Boxes screen.  At this point, the 

left image illustrates how the inputs on the DIG-713A have been allocated, which is incorrect.  

The Card Input - # column represents the DIG-713A's inputs, the center Box column displays 

which box the input has been assigned to, and the right-hand Box Input column represents 

which input number (box input number) the DIG-713A's input has been assigned to.  If the OK 

button were pushed at this point, the HCU would generate a report informing the user that 

there are conflicts with the input/output assignments, see Figure 6-6. 

Figure 6-6 - Input/Output Conflict Report 

 

The Box Inputs need to be adjusted to reflect the correct Box Input number being used in each 

box.  Click on each Box Input number and update to the correct value, 9-13, and then click OK in 

the bottom right to save the changes.  See the right-hand image in Figure 6-7. 
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Figure 6-7 - Updating Box Input Numbers  

 

 

Click the Hardware Summary button to review that the changes have been made, see Figure 

6-8.  Click Close and then exit the HCU and click Yes to save the changes if prompted. 

Figure 6-8 - Updated Inputs for Box 1 
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Additional Racks 

When running multiple racks, it is necessary to determine which card is connected to which 

rack.  The following examples will illustrate how to do this using MED Test.  For assistance with 

MED Test please see DOC-200, MED Test. 

 

DIG-705 USB Cards 

In MED Test open the DIG-705 Interface Card test window by clicking Misc Modules > DIG-705 

Interface Card or by pressing Shift+F5.  The screen shown in Figure 6-9 will appear. 

Figure 6-9 – DIG-705 Interface Card Test Window in MED Test  

 

 

The Identify button when clicked will cause the IN LED on the DIG-705 to flash.  Click Stop 

Identify to stop the flashing. 

It is possible to change the order of the DIG-705s and racks by dragging and dropping the DIG-

705 in the list until it is in the desired order. 

When Rack 1 is determined, it is suggested that the rack be labeled Rack 1.  Repeat this process 

for each additional rack. 

 

DIG-704 PCI Cards 

Follow the steps in Chapter 3, Quick Start Guide to size the rack and add SmartCtrl cards, or the 

steps above to add different types of cards. 

In MED Test open the SmartCtrl test window by clicking SmartCtrl > DIG-716B / DIG-703B or by 

pressing Ctrl+F9.  The screen shown in Figure 6-10 will appear.  The first parameter on the left 

labeled Rack determines which PCI Card/Rack MED Test will "talk" to. 
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Figure 6-10 - SmartCtrl Card Test Window in MED Test  

 

 

If the recommended default settings were used, the first SmartCtrl card in the rack will be set to 

Port Address 780, Out Offset Value 0, and will be connected to chamber (box) one.  Starting with 

Rack 1, turn on an output that is known to be connected to an output device in chamber one.  

When the output is turned on in MED Test, the corresponding red output light on SmartCtrl card 

number 1 will turn on and in box number 1 the output device will be activated.  Triggering an 

input in box 1 would turn on the corresponding green input light on SmartCtrl number 1, and in 

MED Test the green input light would illuminate, and the Repeat Count would increment. 

When Rack 1 is determined, it is suggested that the rack and both ends of the ribbon cable be 

labeled Rack 1.  Repeat this process for each additional rack. 
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CHAPTER 7  |DATA FILE OPTIONS 

This section expands on the data file options presented in the Data File Options section of 

Chapter 3 and provides examples of each format.  The sample data files below were generated 

using the same procedure and similar approach to triggering inputs. 

Formats For Data Files 

Annotated Data File 

It is recommended that the default Annotated option be used.  Annotated data files contain all 

pertinent experiment information and all data variables by default.  See the sample data file 

below.  The data variables displayed, number of columns and printing format may all be 

adjusted via the MedState Notation (MSN) program used to run the experiment.  See DOC-301, 

MED-PC Programmer's Manual for more information on MSN. 

 

Sample Annotated Data File 

File: C:\MED-PC\DATA\!FORMAT.1 

Start Date:  5/6/16 

End Date:  5/6/16 

Subject: 35F 

Experiment: 5CTRL 

Group: 2 

Box: 3 

Start Time: 22:06:43 

End Time: 22:07:41 

MSN: TEMP 

A:       5.000 

B:       3.000 

D:       1.000 

E:       0.000 

F:       0.000 

G:       0.000 

H:       0.000 

I:      18.000 

J:       0.000 

K:       0.000 

L:       0.000 

M:       0.000 

N:       0.000 

O:       0.000 

P:       0.000 

Q:       0.000 

R:       0.000 

S:       0.000 

T:      22.000 

U:       0.000 

V:       0.000 

W:       0.000 

X:       5.000 

Y:       0.000 

Z:       0.000 

C: 

     0:       5.100       7.100       10.100        5.100        7.100 

     5:       0.200      12.100        3.100        5.100        5.100 

    10:       6.100       0.200       13.100       10.100       11.100 

    15:       8.100       7.100        0.200 
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Stripped, C Array Only 

This format produces a data set with no simple variables and only the C array, if it contains any 

data.  If the C Array is empty, only the header information will be presented.  The last three lines 

of the data set would be 0, 1, 0 to indicate no simple variables and one array with no data 

elements. 

 

Sample Stripped, C Array Only Data File 

5  --Month box was loaded 

06  --Day box was loaded 

16  --Year box was loaded 

5  --Month session ended 

06  --Date session ended 

16  --Year session ended 

35F  --Subject 

5CTRL --Experiment 

2  --Group 

3  --Box 

22  --Hour when box was loaded.(24-Hour format) 

25  --Minutes when box was loaded 

34  --Seconds when box was loaded 

22  --Hour when session ended 

25  --Minutes when session ended 

38  --Seconds when session ended 

0  --Total number of simple variables 

1  --There was 1 array declared in the MPC procedure 

18  --1st Array has 18 elements 

5.1  --Begin 1st Array C.  Element C(0) 

7.1  --Element C(1) 

10.1  --Element C(2) 

5.1  --Element C(3) 

7.1  --Element C(4) 

0.2  --Element C(5) 

12.1  --Element C(6) 

3.1  --Element C(7) 

5.1  --Element C(8) 

5.1  --Element C(9) 

6.1  --Element C(10) 

0.2  --Element C(11) 

13.1  --Element C(12) 

10.1  --Element C(13) 

11.1  --Element C(14) 

8.1  --Element C(15) 

7.1  --Element C(16) 

0.2  --Element C(17) 

\Test Procedure - Simulated R 

 

Stripped, With Variable Identification 

This format provides the same information as the Stripped, C Array Only format, with the added 

features of maintaining alphabetical order of variables and arrays and identifying the number of 

elements assigned to each variable.  Therefore, simple variables are always associated with one 

element, while arrays may contain from 1 to 1,000,000 elements.  Unlike the simple stripped 

format, it is not necessary to have access to the .MPC code that produced the data set in order 

to match variable letters to data elements. 
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Sample Stripped With Variable Identification Data File 

5       --Month box was loaded 

06      --Day box was loaded 

98      --Year box was loaded 

5       --Month session ended 

06      --Date session ended 

98      --Year session ended 

35F     --Subject 

5CTRL   --Experiment 

2       --Group 

3       --Box 

22      --Hour when box was loaded.(24-Hour format) 

28      --Minutes when box was loaded 

12      --Seconds when box was loaded 

22      --Hour when session ended 

28      --Minutes when session ended 

16      --Seconds when session ended 

25      --Total number of simple variables 

1       --There is 1 Array declared in MPC Procedure 

.3      --.3 is a "Marker Number" only (Data analysis 

          programs may use this value to identify the 

          start of variable identification.) 

1       --A has 1 Element (was a simple variable) 

1       --B has 1 Element (was a simple variable) 

18      --C was an Array with 18 elements 

1       --D has 1 Element (was a simple variable) 

1       --E has 1 Element (was a simple variable) 

1       --F has 1 Element (was a simple variable) 

1       --G has 1 Element (was a simple variable) 

1       --H has 1 Element (was a simple variable) 

1       --I has 1 Element (was a simple variable) 

1       --J has 1 Element (was a simple variable) 

1       --K has 1 Element (was a simple variable) 

1       --L has 1 Element (was a simple variable) 

1       --M has 1 Element (was a simple variable) 

1       --N has 1 Element (was a simple variable) 

1       --O has 1 Element (was a simple variable) 

1       --P has 1 Element (was a simple variable) 

1       --Q has 1 Element (was a simple variable) 

1       --R has 1 Element (was a simple variable) 

1       --S has 1 Element (was a simple variable) 

1       --T has 1 Element (was a simple variable) 

1       --U has 1 Element (was a simple variable) 

1       --V has 1 Element (was a simple variable) 

1       --W has 1 Element (was a simple variable) 

1       --X has 1 Element (was a simple variable) 

1       --Y has 1 Element (was a simple variable) 

1       --Z has 1 Element (was a simple variable) 

5       --Variable A has a value of 5 

3       --Variable B has a value of 3 

5.1     --Begin Array "C". Element C(0) 

7.1     --Element C(1) 

10.1    --Element C(2) 

5.1     --Element C(3) 

7.1     --Element C(4) 

0.2     --Element C(5) 

12.1    --Element C(6) 

3.1     --Element C(7) 

5.1     --Element C(8) 

5.1     --Element C(9) 

6.1     --Element C(10) 

0.2     --Element C(11) 

13.1    --Element C(12) 

10.1    --Element C(13) 

11.1    --Element C(14) 

8.1     --Element C(15) 

7.1     --Element C(16) 

0.2     --Element C(17) 

1       --Variable D has a value of 1 

0       --Variable E has a value of 0 
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0       --Variable F has a value of 0 

0       --Variable G has a value of 0 

0       --Variable H has a value of 0 

18      --Variable I has a value of 18 

0       --Variable J has a value of 0 

0       --Variable K has a value of 0 

0       --Variable L has a value of 0 

0       --Variable M has a value of 0 

0       --Variable N has a value of 0 

0       --Variable O has a value of 0 

0       --Variable P has a value of 0 

0       --Variable Q has a value of 0 

0       --Variable R has a value of 0 

0       --Variable S has a value of 0 

22      --Variable T has a value of 22 

0       --Variable U has a value of 0 

0       --Variable V has a value of 0 

0       --Variable W has a value of 0 

5       --Variable X has a value of 5 

0       --Variable Y has a value of 0 

0       --Variable Z has a value of 0 

\Test Procedure - Simulated R 

File Naming Conventions 

Append data to a file with name based on experiment, group and subject identifiers 

If this option is selected, be sure to complete one or more of the identifier fields when opening a 

session, otherwise, all data will be saved to a file named "Subject_Experiment_Group.txt". 

 

Append all data for a given calendar day to a file with name based on date 

This selection will base the file name on the date the session was opened, not necessarily on the 

date the session is closed or when the data is written.  A session opened on April 18, 2016 will 

result in a data file named "2016-04-18.txt". 

 

Create new file for every session, named according to date, time and subject 

This selection will base the file name on information entered at the time the session was 

opened.  It is much more specific than either previous selection and will result in a single file for 

each animal, each day.  The file name for an animal with subject ID, "A235m" run at 10:30 AM 

on April 18, 2016 will be "2016-04-18_10h30m_Subject A235m.txt". 

Data Directory 

The default data directory for storing session data is "C:\MED-PC\Data", it is recommended that 

this data directory not be changed. 

Automatic Data Backup Frequency 

MED-PC® will automatically save data while a session is open.  The data will be saved to 

"C:\MED-PC\Backups" with a file name based on the date, time, subject, and box that the 

experiment is running in.  These files are not intended as permanent data and any backup files 

that are greater than 7 days old are automatically deleted by MED-PC®.  The recommended save 
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frequency is 10 minutes.  This will retain most of the data, especially in long sessions, in the 

event of an unexpected computer failure.  Frequencies less than 10 minutes may degrade the 

performance of other functions, such as screen updates, depending on the speed and resources 

of the computer.  If a backup file is not desired, set the frequency value to 0. 

After the data file options have been set, click OK to exit the Data File Options screen and return 

to MED-PC®. 
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CHAPTER 8   | INSTALLING MED-PC® IN EMULATION MODE 

Emulation mode enables the user to develop MSN programs without being connected to the 

interface hardware.  Emulation mode may be enabled during the installation of MED-PC®, or 

after installation using a Command Line Option. 

To install MED-PC® in emulation mode, insert the MED-PC® CD and when the main screen 

appears click Install in Hardware Emulation mode (Figure 8-1) to begin the installation. 

Figure 8-1 – MED-PC® Installation Screen 

 

 

When the installation is complete, a shortcut for starting MED-PC® in Emulation Mode will be 

placed on the desktop (Figure 8-2). 

Figure 8-2 - MED-PC® Emulation Mode Desktop Shortcut 
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CHAPTER 9  | COMMAND LINE OPTIONS 

Command line options allow the user to instruct MED-PC® to start under specified conditions or 

launch a macro upon opening.  Multiple desktop shortcut icons for launching MED-PC®, each 

with its own special properties, may be used.  Note however, only one instance of MED-PC® may 

be launched at a time. 

Command Line Start Up Options 

There are three options for starting MED-PC® under specific conditions: 

 /E: Start MED-PC® in emulation mode. 

/I: Force MED-PC® to start and assume an interface cabinet is connected and powered 

up. 

/INSTALL="name_of_config_file.xml": Start MED-PC® using the specified hardware 

configuration file. 

Note: For the /INSTALL command to function, there must be no white spaces around the "=" 

sign. 

Emulation Mode Example 

Begin by creating a desktop shortcut.  In Windows Explorer navigate to C:\MED-PC, right-click on 

the MPCLoader.exe file (it may only say MPCLoader), select Send To and click Desktop (create 

shortcut).  See Figure 9-1. 

Figure 9-1 - Creating a Desktop Shortcut Icon 

 

 

Return to the desktop, right click on the MPCLoader - Shortcut icon, select Rename and give the 

icon a distinct name such as MED-PC – Emulation Mode and click the Enter key.  Right click on 

the icon again and select Properties to open the Shortcut Properties screen.  On the Shortcut 

tab, add a space and then /E to the end of the target, see Figure 9-2.  Click OK to save the 

change and exit the properties screen.  Double-click the newly created MED-PC – Emulation 
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Mode icon to start MED-PC® in emulation mode when the computer is not connected to the 

interface cabinet. 

Figure 9-2 - Modify the Shortcut Target 
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Alternate Configuration File Example 

Create a desktop icon as outlined in the Emulation Mode Example above.  In the Target window 

add the /INSTALL command and the name of the .xml configuration file.  In the example in 

Figure 9-3  the name of the alternate configuration file is "6BoxSetUp.xml". 

Figure 9-3 - /INSTALL Command Line Option Example 

 

 

Command Line Macro Options 

MED-PC® may be instructed to run a macro as soon as it loads by adding the macro path and 

name to the end of the Target, similar to the start-up options described above.  Follow the steps 

above to create a desktop icon with a distinctive name and add the path and name of the macro 

to the end of the Target. 

By default, macros are stored in C:\MED-PC\Macro.  Assume we have a macro called 

SampleMacro.MAC, to the end of the target we would add a space and "C:\MED-

PC\Macro\SampleMacro.MAC" (quotes are required) to the end of the target to have MED-PC® 

run the SampleMacro.MAC as soon as it loads.  
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CHAPTER 10  | TERMINAL COMMANDS 

The terminal commands in Table 1 allow the user to enter MED-PC® commands directly into the 

terminal window.  These terminal commands perform the same functions as the button and 

menus within the user interface. 

Table 1 - Terminal Commands 

Command Description Arguments Example Notes 

C Change 

Variable Value 

C;Var/Arr 

Element/Alias/Equated 

Var;NewValue;Boxes 

C;A;10;1-2 Set A to 10 in Boxes 1 & 2 

CLS Clear Screen    

CO Session 

Comment 

CO;Boxes CO;3;The 

rat seems 

agitated 

Appends remark about rat 

to Box 3 session comments 

G Gets Variable 

Value 

G;Var/Arr 

Elements/Alias/Equated 

Var;Boxes 

G;A(5);1-2 Displays value of A(5) in 

Boxes 1 & 2 

K Issues Keyboard 

(K-Pulse) Signal 

K;K Number;Boxes K;10;1 Send K10 to Box 1 

L Loads One Box L;Box;Subj;Expt;Grp;Pgm (no 

extension) 

L;2;101;3;

2;FrTrain 

Load Box 2, Subject 101, 

Experiment 3, Group 2, 

Program FrTrain 

LOFF Turns Off 

Locked On 

Output 

LOFF;Output;Boxes LOFF;3;1-

2 

Turn Off Locked On Output 

3 in Boxes 1 & 2 

LON Locks On 

Output 

LON;Output;Boxes LON;2;A Lock On Output 2 in All 

Boxes 

M Plays Macro M;Macro Name (.mac extension 

and file path optional) 

M;Macro1 Play Macro1 

OFF Turns Off 

Output 

OFF;Output;Boxes OFF;3;1-2 Turn Off Output 3 in Boxes 

1 & 2 

ON Turns On 

Output 

ON;Output;Boxes ON;2;A Turn On Output 2 in All 

Boxes 

P Prints Box P;Boxes P;1 Print Box 1 

R Issues 

Simulated 

Response 

R;Response Number;Boxes R;1;4 Send R1 to Box 4 

RESET Resets the error 

indicator 
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S Issues Start 

Command 

S;Boxes S;3 Start Box 3 

STD Stops Box and 

Discards Data 

STD;Boxes STD;1-3 Stops and discards data in 

Boxes 1, 2, & 3 

STS Stops Box and 

Saves Data to 

Disk 

STS;Boxes STS;A Stops and saves data for all 

Boxes 

 

Box numbers may be specified individually, as a comma separated list (e.g., 1,3,5), expressed as 

a range (e.g., 3-7), or all boxes may be selected with A. 

Pressing the up and down arrows will recall the last 100 commands. 

Pressing ? will display the help for all commands.  Pressing ?COMMAND NAME (e.g., ?C) will 

display the help for that command. 
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CHAPTER 11    | CONTACT INFORMATION 

MED-PC® is already being used in more laboratories around the world than any comparable 

product; however, it is always being improved and comments on how it might be enhanced 

further are welcome. 

Please contact MED Associates, Inc. for information regarding any of our products. 

Visit our website at www.med-associates.com for contact information. 

For technical questions, call 802-527-2343 or email support@med-associates.com. 

 

http://www.razelscientific.com/
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